fbset: ensure it builds after busybox if both are enabled
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 31 Jan 2011 19:40:25 +0000 (16:40 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 31 Jan 2011 19:45:14 +0000 (20:45 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/fbset/fbset.mk

index 8926f4c4727c380b2056b6a6740bd817973ca455..b5b5ab80909fe21a108e52c6dbbd406fbb8991dc 100644 (file)
@@ -3,10 +3,16 @@
 # fbset
 #
 #############################################################
+
 FBSET_VERSION = 2.1
 FBSET_SOURCE = fbset-$(FBSET_VERSION).tar.gz
 FBSET_SITE = http://users.telenet.be/geertu/Linux/fbdev
 
+# Make sure full fbset wins over busybox fbset
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+FBSET_DEPENDENCIES += busybox
+endif
+
 define FBSET_BUILD_CMDS
        $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D)
 endef