Remove INITRAMFS_TARGET variable
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 4 Nov 2010 16:21:28 +0000 (17:21 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Nov 2010 18:26:27 +0000 (19:26 +0100)
This used to be needed when the filesystem code was rewritten, but not
the Linux compilation code. Now that the Linux compilation code has
been rewritten, the mechanism to ensure that initramfs gets built
*before* the kernel so that it can be integrated is different, and
this INITRAMFS_TARGET variable is no longer used.

See f507921d391bb2578261a9e45c003e72302dc67a for details.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/initramfs/initramfs.mk

index 30969a4c921afcccfeda22a5888394c15f880bb3..dd6aa94adffc71a8984069b188246981e0e92670 100644 (file)
@@ -6,12 +6,6 @@
 #
 #############################################################
 
-ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
-INITRAMFS_TARGET:=initramfs-root
-else
-INITRAMFS_TARGET:= #nothing
-endif
-
 define ROOTFS_INITRAMFS_INIT_SYMLINK
        if [ ! -e $(TARGET_DIR)/init ]; then \
                ln -s sbin/init $(TARGET_DIR)/init; \