package/zstd: avoid compilation during host-zstd install step
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Mon, 28 Sep 2020 11:42:26 +0000 (13:42 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 28 Sep 2020 20:04:15 +0000 (22:04 +0200)
The host-zstd-build step was not actually compiling the library:

make[1]: Entering directory '/buildroot/output/build/host-zstd-1.4.5/lib'
make[1]: Nothing to be done for 'default'.
make[1]: Leaving directory '/buildroot/output/build/host-zstd-1.4.5/lib'

and the actual compilation was part of the install step.
This is not how other Buildroot packages work.

Make sure to specify which library targets we want instead. The total amount
of compiled files does not change with this patch.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/zstd/zstd.mk

index e2ba12b058f5da09826d78b565682610c59e44ba..35002da33254e9c19d4ae601fb92dd2997775d45 100644 (file)
@@ -71,7 +71,7 @@ endef
 # note: no 'HAVE_...' options for host library build only
 define HOST_ZSTD_BUILD_CMDS
        $(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) \
-               -C $(@D)/lib
+               -C $(@D)/lib libzstd.a libzstd
        $(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) \
                -C $(@D) zstd
 endef