mpv: bump to version 0.18.0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 26 Jun 2016 18:12:05 +0000 (15:12 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Jun 2016 19:46:32 +0000 (21:46 +0200)
gpl3 option removed so drop it otherwise it results in build failure.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mpv/Config.in
package/mpv/mpv.hash
package/mpv/mpv.mk

index 1cef6c50094d18b3a1e195bff3a91a05d3b0dd36..25288a43d4c3aff54e977c60a7d76afe45cb1ef9 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_MPV
        bool "mpv"
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_5
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        select BR2_PACKAGE_FFMPEG
        select BR2_PACKAGE_FFMPEG_SWSCALE
@@ -14,6 +15,7 @@ config BR2_PACKAGE_MPV
 
          https://mpv.io/
 
-comment "mpv needs a toolchain w/ threads"
+comment "mpv needs a toolchain w/ threads, gcc >= 4.5"
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
-       depends on !BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || \
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_5
index da51f3ab1a5d4fb34546332ba31c6c273f2816af..8d9c9d15ff5593e49e45f4834a4851397ad20390 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 602cd2b0f5fc7e43473234fbb96e3f7bbb6418f15eb8fa720d9433cce31eba6e        v0.17.0.tar.gz
+sha256 b656638d4f6bce2621baaacb60d8be384aa492fcd86dfd43996aaa2c16fee02b        v0.18.0.tar.gz
 sha256 01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b        waf-1.8.12
index cd8c31bd8f328344fb3422e79b730692a51256d5..7ecac9e156efc92a0f40aaf653d05ca1681f6ac0 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-MPV_VERSION = 0.17.0
+MPV_VERSION = 0.18.0
 MPV_WAF_VERSION = 1.8.12
 MPV_SITE = https://github.com/mpv-player/mpv/archive
 MPV_SOURCE = v$(MPV_VERSION).tar.gz
@@ -23,7 +23,6 @@ MPV_CONF_OPTS = \
        --disable-cdda \
        --disable-cocoa \
        --disable-coreaudio \
-       --disable-gpl3 \
        --disable-libguess \
        --disable-libv4l2 \
        --disable-opensles \