Add staging libraries directories to -L in external case
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 6 May 2010 17:58:45 +0000 (19:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 6 May 2010 18:18:41 +0000 (20:18 +0200)
In order to solve issues of libtool trying to link target components
against host libraries, it seems that specifying -L$(STAGING_DIR)/lib
and -L$(STAGING_DIR)/usr/lib works.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.in

index 0bec9a1c27040986d83d172566cf11f27c6df65b..2ed7f423c517018a0c74a737d287a0a37e33e3c1 100644 (file)
@@ -98,6 +98,7 @@ else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
 TARGET_CFLAGS+=--sysroot $(STAGING_DIR)/
 TARGET_CXXFLAGS=$(TARGET_CFLAGS)
 TARGET_LDFLAGS=--sysroot $(STAGING_DIR)/
+TARGET_LDFLAGS+=-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
 endif
 #########################################################################