lua: ensure that host-lua does not depend on host-readline and host-ncurses
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Jul 2012 12:40:18 +0000 (14:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Jul 2012 12:40:18 +0000 (14:40 +0200)
Commit ad6af5819f88bac9ca7f50e565c4fc68d3e408cc removed the
HOST_LUA_DEPENDENCIES assignement to the empty variable, so from that
commit, the dependencies of host-lua are automatically computed from
the dependencies of lua. Since lua can depend on readline and ncurses,
it means that host-lua can depend on host-readline and host-ncurses,
and the host-readline package does not exist in Buildroot. Since there
is no reason to build host-lua with readline/ncurses support, just
re-add the HOST_LUA_DEPENDENCIES variable.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Francois Perrad <fperrad@gmail.com>
package/lua/lua.mk

index 8f71fc229fc7eee6a19e6bdf079f85b41edf24d1..074b9adb4034764e4c64de87a8c16576f288b0ce 100644 (file)
@@ -23,6 +23,9 @@ else
        LUA_CFLAGS += -DLUA_USE_POSIX -DLUA_USE_DLOPEN
 endif
 
+# We never want to have host-readline and host-ncurses as dependencies
+# of host-lua.
+HOST_LUA_DEPENDENCIES =
 HOST_LUA_CFLAGS = -Wall -fPIC -DLUA_USE_DLOPEN -DLUA_USE_POSIX
 HOST_LUA_MYLIBS = -ldl