package/amd-catalyst: Add support AMD CCCLE
authorRomain Perier <romain.perier@free-electrons.com>
Tue, 23 Aug 2016 12:19:49 +0000 (14:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Aug 2016 17:15:09 +0000 (19:15 +0200)
The AMD Catalyst Linux driver includes a graphical controler center for AMD
graphics accelerators, called Catalyst Controler Center. This commits
adds support to install this tool by adding a separated prompt.

Signed-off-by: Romain Perier <romain.perier@free-electrons.com>
[Thomas:
 - As noticed by Yann, fixed the dependency of the comment related to
   the Qt PNG functionality.
 - Also add the Qt PNG dependency to the BR2_PACKAGE_AMD_CATALYST_CCCLE
   option itself, noticed by Yann.
 - Add an empty line, also noticed by Yann.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/amd-catalyst/Config.in
package/amd-catalyst/amd-catalyst.mk

index b10ed3b11fe14d8322d2660990f9a95444d82e87..55099accf091a0440a48e84a5e0c7ad160c67ef3 100644 (file)
@@ -45,6 +45,23 @@ config BR2_PACKAGE_AMD_CATALYST_CMDLINE_TOOLS
        help
          Build and install the AMD command line tools.
 
+comment "Catalyst Control Center needs Qt4 with X11 and PNG support"
+       depends on !BR2_PACKAGE_QT || !BR2_PACKAGE_QT_X11 \
+               || BR2_PACKAGE_QT_NOPNG
+
+config BR2_PACKAGE_AMD_CATALYST_CCCLE
+       bool "Catalyst Control Center"
+       depends on BR2_PACKAGE_QT
+       depends on BR2_PACKAGE_QT_X11
+       depends on !BR2_PACKAGE_QT_NOPNG
+       select BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # procps-ng
+       select BR2_PACKAGE_PROCPS_NG # runtime
+       select BR2_PACKAGE_QT_GUI_MODULE
+       select BR2_PACKAGE_QT_ACCESSIBILITY
+       help
+         Installs the Catalyst Control Center, a Qt graphical tool to
+         control AMD graphics accelerators.
+
 endif
 
 comment "amd-catalyst kernel module needs a kernel to be built"
index 4c1844c4d3504384d7c8e36002b1b6ba0cd13e21..07eb0faf7f4f53d84c21db1b73f55bd52e64459f 100644 (file)
@@ -128,6 +128,15 @@ define  AMD_CATALYST_INSTALL_CMDLINE_TOOLS
 endef
 endif
 
+ifeq ($(BR2_PACKAGE_AMD_CATALYST_CCCLE), y)
+define AMD_CATALYST_INSTALL_CCCLE
+       $(INSTALL) -m 0755 $(AMD_CATALYST_ARCH_DIR)/usr/X11R6/bin/amdcccle \
+               $(TARGET_DIR)/usr/bin/amdcccle
+       $(INSTALL) -m 0755 $(AMD_CATALYST_ARCH_DIR)/usr/sbin/amdnotifyui \
+               $(TARGET_DIR)/usr/sbin/amdnotifyui
+endef
+endif
+
 define AMD_CATALYST_INSTALL_STAGING_CMDS
        $(call AMD_CATALYST_INSTALL_STAGING_XORG)
 endef
@@ -135,6 +144,7 @@ endef
 define AMD_CATALYST_INSTALL_TARGET_CMDS
        $(call AMD_CATALYST_INSTALL_XORG)
        $(call AMD_CATALYST_INSTALL_CMDLINE_TOOLS)
+       $(call AMD_CATALYST_INSTALL_CCCLE)
 endef
 
 $(eval $(generic-package))