sdl: disable rpath via configure option
authorRodrigo Rebello <rprebello@gmail.com>
Thu, 17 Mar 2016 06:02:22 +0000 (03:02 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 17 Mar 2016 09:14:58 +0000 (10:14 +0100)
The -rpath option was being stripped from sdl-config via a post install
staging hook, but the same wasn't being done for sdl.pc. Because of
this, packages that detect SDL via pkg-config ended up passing
'-Wl,-rpath,/usr/lib' to the linker, which caused build failures under
certain circumstances since libraries were being looked for in the wrong
directory.

Fix by passing the --disable-rpath option to the SDL configure script,
which takes care of disabling -rpath everywhere. This also allows the
SDL_FIXUP_SDL_CONFIG hack to be completely removed.

Fixes:

  http://autobuild.buildroot.net/results/624/62499217eeaf3228b46652e3f65776d7ece8fce6/
  http://autobuild.buildroot.net/results/cc1/cc1f78f6c43e3a7bf3ed80d759d9c4d7363d0e48/

Signed-off-by: Rodrigo Rebello <rprebello@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sdl/sdl.mk

index cc1ad067316bcc82c3604467380a70b7672a6563..38b4b977525f122dbf2df3dce55902accfb2afd6 100644 (file)
@@ -80,6 +80,7 @@ SDL_DEPENDENCIES += mesa3d
 endif
 
 SDL_CONF_OPTS += \
+       --disable-rpath \
        --enable-pulseaudio=no \
        --disable-arts \
        --disable-esd \
@@ -96,13 +97,5 @@ HOST_SDL_CONF_OPTS += \
 
 SDL_CONFIG_SCRIPTS = sdl-config
 
-# Remove the -Wl,-rpath option.
-define SDL_FIXUP_SDL_CONFIG
-       $(SED) 's%-Wl,-rpath,\$${libdir}%%' \
-               $(STAGING_DIR)/usr/bin/sdl-config
-endef
-
-SDL_POST_INSTALL_STAGING_HOOKS += SDL_FIXUP_SDL_CONFIG
-
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))