libubox: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 20 Mar 2014 22:17:10 +0000 (23:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 23 Mar 2014 20:19:21 +0000 (21:19 +0100)
[Peter: needs !static, use += for _DEPENDENCIES/_CONF_OPT]
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/libubox/Config.in [new file with mode: 0644]
package/libubox/libubox.mk [new file with mode: 0644]

index 89867347220f76aa5557402bf7e3277249f80020..66ded0b4a507d6b96351a7b8741f442485b7d79a 100644 (file)
@@ -791,6 +791,7 @@ source "package/libsigc/Config.in"
 source "package/libsigsegv/Config.in"
 source "package/libtasn1/Config.in"
 source "package/libtpl/Config.in"
+source "package/libubox/Config.in"
 source "package/libunwind/Config.in"
 source "package/liburcu/Config.in"
 source "package/linux-pam/Config.in"
diff --git a/package/libubox/Config.in b/package/libubox/Config.in
new file mode 100644 (file)
index 0000000..d458067
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LIBUBOX
+       bool "libubox"
+       depends on !BR2_PREFER_STATIC_LIB
+       help
+         This library originates from the OpenWrt project to
+         handle the configuration file infrastructure, but can
+         also be used for the same purposes in projects other
+         than OpenWrt.
+
+         http://nbd.name/gitweb.cgi?p=luci2/libubox.git;a=summary
+
+comment "libubox needs a toolchain w/ dynamic library"
+       depends on BR2_PREFER_STATIC_LIB
diff --git a/package/libubox/libubox.mk b/package/libubox/libubox.mk
new file mode 100644 (file)
index 0000000..0743acc
--- /dev/null
@@ -0,0 +1,18 @@
+################################################################################
+#
+# libubox
+#
+################################################################################
+
+LIBUBOX_VERSION = bbd846ec2d72b2629758b69dc122ac0b0f2c3e4b
+LIBUBOX_SITE = git://nbd.name/luci2/libubox.git
+LIBUBOX_LICENSE = LGPLv2.1, GPLv2, BSD-3c, MIT
+LIBUBOX_INSTALL_STAGING = YES
+
+ifeq ($(BR2_PACKAGE_LUA),y)
+       LIBUBOX_DEPENDENCIES += lua
+else
+       LIBUBOX_CONF_OPT += -DBUILD_LUA:BOOL=OFF
+endif
+
+$(eval $(cmake-package))