neon: add optional ssl support
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 20 Dec 2009 22:49:45 +0000 (23:49 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 20 Dec 2009 22:49:45 +0000 (23:49 +0100)
Signed-off-by: Nigel Kukard <nkukard@lbsd.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/neon/Config.in
package/neon/neon.mk

diff --git a/CHANGES b/CHANGES
index 01b25aa3127d6b852b6a8f257191de6e0646391b..4d439bcebf29442a195f3abe087a1e3234abda78 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -3,8 +3,9 @@
        New packages: libcdaudio, libdvdnav, libdvdread, hostapd, tcpreplay
 
        Updated/fixed packages: autoconf, bind, binutils, busybox,
-       directfb, gst-plugins-bad, hal, iw, libfuse, libpcap, lighttpd,
-       mesa, mpg123, mtd-utils, pcre, qt, sshfs, tremor, u-boot, usbutils
+       directfb, gst-plugins-bad, hal, iw, libfuse, libpcap,
+       lighttpd, mesa, mpg123, mtd-utils, neon, pcre, qt, sshfs,
+       tremor, u-boot, usbutils
 
        Issues resolved (http://bugs.uclibc.org):
 
index ce72a2fb6c7a64a584144357494f780771e1df7d..318e4c6a3131b96950b43179755620fb33efec11 100644 (file)
@@ -12,6 +12,12 @@ config BR2_PACKAGE_NEON_ZLIB
        help
          build with ZLIB support
 
+config BR2_PACKAGE_NEON_SSL
+       bool "SSL support"
+       select BR2_PACKAGE_OPENSSL
+       help
+         build with SSL support
+
 choice
        prompt "XML Support"
        default BR2_PACKAGE_NEON_NOXML
index 1f26a0c96d4f3fa58173d2762a5de114c4844c8a..ed5f999685f89df363e8d02116bd8228700c45be 100644 (file)
@@ -22,6 +22,12 @@ NEON_DEPENDENCIES+=zlib
 else
 NEON_CONF_OPT+=--without-zlib
 endif
+ifeq ($(BR2_PACKAGE_NEON_SSL),y)
+NEON_CONF_OPT+=--with-ssl
+NEON_DEPENDENCIES+=openssl
+else
+NEON_CONF_OPT+=--without-ssl
+endif
 ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
 NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
 NEON_CONF_OPT+=--with-libxml2=no