package/imagemagick: add optional libraw support
authorPeter Seiderer <ps.report@gmx.net>
Fri, 19 Feb 2021 23:02:55 +0000 (00:02 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 26 Feb 2021 23:39:09 +0000 (00:39 +0100)
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/imagemagick/imagemagick.mk

index 5b4ba63c85c5fc642aa898aa9b2a4357dfb297ff..30200e95b0ddc5fd473956cc12c599ccd1379815 100644 (file)
@@ -88,6 +88,13 @@ else
 IMAGEMAGICK_CONF_OPTS += --without-png
 endif
 
+ifeq ($(BR2_PACKAGE_LIBRAW),y)
+IMAGEMAGICK_CONF_OPTS += --with-raw
+IMAGEMAGICK_DEPENDENCIES += libraw
+else
+IMAGEMAGICK_CONF_OPTS += --without-raw
+endif
+
 ifeq ($(BR2_PACKAGE_LIBRSVG),y)
 IMAGEMAGICK_CONF_OPTS += --with-rsvg
 IMAGEMAGICK_DEPENDENCIES += librsvg
@@ -182,6 +189,7 @@ HOST_IMAGEMAGICK_CONF_OPTS = \
        --without-openexr \
        --without-perl \
        --without-raqm \
+       --without-raw \
        --without-wmf \
        --without-x \
        --without-zip \