package/ddrescue: work around gcc bug 85180
authorGiulio Benetti <giulio.benetti@micronovasrl.com>
Tue, 21 May 2019 13:39:24 +0000 (15:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 May 2019 19:41:47 +0000 (21:41 +0200)
With Microblaze Gcc version < 8.x the build hangs due to gcc bug
85180: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85180. The bug
shows up when building ddrescue with optimization but not when
building with -O0. To work around this, if
BR2_TOOLCHAIN_HAS_GCC_BUG_85180=y we force using -O0.

Fixes:

  http://autobuild.buildroot.net/results/2af69401acb76be3d3fd427d1c58fed3af33bf9b/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
[Thomas: tweak CFLAGS logic, improve commit log]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ddrescue/ddrescue.mk

index 9432e7a16dfc17d3ea294bd70b4ffe88a80f6c75..b7564d5971e5a9e6f87859fccdac509b31d1c221 100644 (file)
@@ -18,8 +18,14 @@ define DDRESCUE_CONFIGURE_CMDS
        )
 endef
 
+DDRESCUE_CXXFLAGS = $(TARGET_CXXFLAGS)
+
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
+DDRESCUE_CXXFLAGS += -O0
+endif
+
 define DDRESCUE_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
+       $(TARGET_MAKE_ENV) $(MAKE) CXXFLAGS="$(DDRESCUE_CXXFLAGS)" -C $(@D)
 endef
 
 define DDRESCUE_INSTALL_TARGET_CMDS