package/git: fix build with curl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 11 Jun 2019 17:05:21 +0000 (19:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 11 Jun 2019 20:37:46 +0000 (22:37 +0200)
curl-config path can be set through ac_cv_prog_CURL_CONFIG and not
ac_cv_prog_curl_config

Fixes:
 - http://autobuild.buildroot.org/results/4b22f761795d8760dac6ddfd40934259f0135a4d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/git/git.mk

index 8d1fcd239990646b39f0a97e442dea9beeddb201..1b4a1a51e904c6a4d9bb08d5d07bd15237e07dd1 100644 (file)
@@ -35,7 +35,7 @@ ifeq ($(BR2_PACKAGE_LIBCURL),y)
 GIT_DEPENDENCIES += libcurl
 GIT_CONF_OPTS += --with-curl
 GIT_CONF_ENV += \
-       ac_cv_prog_curl_config=$(STAGING_DIR)/usr/bin/$(LIBCURL_CONFIG_SCRIPTS)
+       ac_cv_prog_CURL_CONFIG=$(STAGING_DIR)/usr/bin/$(LIBCURL_CONFIG_SCRIPTS)
 else
 GIT_CONF_OPTS += --without-curl
 endif