xerces: don't disable network without curl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 9 Oct 2018 17:25:19 +0000 (19:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 10 Oct 2018 06:56:13 +0000 (08:56 +0200)
curl is not the only network accessor, xerces can also use the socket
API if sys/socket is available.
So replace --disable-network by --disable-netaccessor-curl

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/xerces/xerces.mk

index da088d8e1c38773fd54b27d5e11beeb619ed08e2..d74b1e2d3d4512a0d8eaa189fd80302eaed3f6f2 100644 (file)
@@ -34,7 +34,7 @@ ifeq ($(BR2_PACKAGE_LIBCURL),y)
 XERCES_CONF_OPTS += --enable-netaccessor-curl --with-curl=$(STAGING_DIR)/usr/lib
 XERCES_DEPENDENCIES += libcurl
 else
-XERCES_CONF_OPTS += --disable-network
+XERCES_CONF_OPTS += --disable-netaccessor-curl
 endif
 
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)