package/thrift: disable qt4
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 7 Mar 2020 09:22:30 +0000 (10:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 7 Mar 2020 21:52:02 +0000 (22:52 +0100)
host-thrift can fail if a broken Qt4 is found on host:

CMake Error in lib/cpp/CMakeLists.txt:
  Imported target "Qt4::QtCore" includes non-existent path

    "/nvmedata/autobuild/instance-4/output-1/host/usr/mkspecs/default"

  in its INTERFACE_INCLUDE_DIRECTORIES.  Possible reasons include:

  * The path was deleted, renamed, or moved to another location.

  * An install or uninstall procedure did not complete successfully.

  * The installation package was faulty and references files it does not
  provide.

Fixes:
 - http://autobuild.buildroot.org/results/57cad5313896c868e99b0b9534678f1c83a386f2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/thrift/thrift.mk

index 6014bbfcdd4f646c7617392484484f4436726222..4260fe7e1c2541c030209ac1e0072fbc5597641b 100644 (file)
@@ -19,6 +19,7 @@ THRIFT_COMMON_CONF_OPTS = -DBUILD_TUTORIALS=OFF \
        -DBUILD_TESTING=OFF \
        -DWITH_PYTHON=OFF \
        -DWITH_JAVA=OFF \
+       -DWITH_QT4=OFF \
        -DWITH_QT5=OFF
 
 THRIFT_CONF_OPTS = $(THRIFT_COMMON_CONF_OPTS) -DBUILD_COMPILER=OFF