- add binutils-2.18 and binutils-2.18.50.0.1
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 17 Sep 2007 11:19:04 +0000 (11:19 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 17 Sep 2007 11:19:04 +0000 (11:19 -0000)
toolchain/binutils/2.18.50.0.1/110-arm-eabi-conf.patch [new file with mode: 0644]
toolchain/binutils/2.18.50.0.1/300-001_ld_makefile_patch.patch [new file with mode: 0644]
toolchain/binutils/2.18.50.0.1/300-012_check_ldrunpath_length.patch [new file with mode: 0644]
toolchain/binutils/2.18/110-arm-eabi-conf.patch [new file with mode: 0644]
toolchain/binutils/2.18/300-001_ld_makefile_patch.patch [new file with mode: 0644]
toolchain/binutils/2.18/300-012_check_ldrunpath_length.patch [new file with mode: 0644]
toolchain/binutils/Config.in
toolchain/binutils/binutils.mk

diff --git a/toolchain/binutils/2.18.50.0.1/110-arm-eabi-conf.patch b/toolchain/binutils/2.18.50.0.1/110-arm-eabi-conf.patch
new file mode 100644 (file)
index 0000000..04e19be
--- /dev/null
@@ -0,0 +1,24 @@
+diff -u binutils-2.17.50.0.17.oorig/configure binutils-2.17.50.0.17/configure
+--- binutils-2.17.50.0.17.oorig/configure      2007-06-18 19:29:28.000000000 +0200
++++ binutils-2.17.50.0.17/configure    2007-06-25 09:58:36.000000000 +0200
+@@ -2224,7 +2224,7 @@
+   arm-*-elf* | strongarm-*-elf* | xscale-*-elf* | arm*-*-eabi* )
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     ;;
+-  arm*-*-linux-gnueabi)
++  arm*-*-linux-gnueabi | arm*-*-linux-uclibcgnueabi)
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     noconfigdirs="$noconfigdirs target-libjava target-libobjc"
+     ;;
+diff -u binutils-2.17.50.0.17.oorig/configure.ac binutils-2.17.50.0.17/configure.ac
+--- binutils-2.17.50.0.17.oorig/configure.ac   2007-06-18 19:29:28.000000000 +0200
++++ binutils-2.17.50.0.17/configure.ac 2007-06-25 09:58:36.000000000 +0200
+@@ -513,7 +513,7 @@
+   arm-*-elf* | strongarm-*-elf* | xscale-*-elf* | arm*-*-eabi* )
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     ;;
+-  arm*-*-linux-gnueabi)
++  arm*-*-linux-gnueabi | arm*-*-linux-uclibcgnueabi)
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     noconfigdirs="$noconfigdirs target-libjava target-libobjc"
+     ;;
diff --git a/toolchain/binutils/2.18.50.0.1/300-001_ld_makefile_patch.patch b/toolchain/binutils/2.18.50.0.1/300-001_ld_makefile_patch.patch
new file mode 100644 (file)
index 0000000..5cb0f61
--- /dev/null
@@ -0,0 +1,24 @@
+diff -u binutils-2.17.50.0.17.oorig/ld/Makefile.am binutils-2.17.50.0.17/ld/Makefile.am
+--- binutils-2.17.50.0.17.oorig/ld/Makefile.am 2007-06-18 19:29:29.000000000 +0200
++++ binutils-2.17.50.0.17/ld/Makefile.am       2007-06-25 10:00:36.000000000 +0200
+@@ -18,7 +18,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+diff -u binutils-2.17.50.0.17.oorig/ld/Makefile.in binutils-2.17.50.0.17/ld/Makefile.in
+--- binutils-2.17.50.0.17.oorig/ld/Makefile.in 2007-06-18 19:29:29.000000000 +0200
++++ binutils-2.17.50.0.17/ld/Makefile.in       2007-06-25 10:00:36.000000000 +0200
+@@ -287,7 +287,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ BASEDIR = $(srcdir)/..
+ BFDDIR = $(BASEDIR)/bfd
+ INCDIR = $(BASEDIR)/include
diff --git a/toolchain/binutils/2.18.50.0.1/300-012_check_ldrunpath_length.patch b/toolchain/binutils/2.18.50.0.1/300-012_check_ldrunpath_length.patch
new file mode 100644 (file)
index 0000000..6e80921
--- /dev/null
@@ -0,0 +1,21 @@
+diff -u binutils-2.17.50.0.17.oorig/ld/emultempl/elf32.em binutils-2.17.50.0.17/ld/emultempl/elf32.em
+--- binutils-2.17.50.0.17.oorig/ld/emultempl/elf32.em  2007-06-18 19:31:40.000000000 +0200
++++ binutils-2.17.50.0.17/ld/emultempl/elf32.em        2007-06-25 10:01:25.000000000 +0200
+@@ -1007,6 +1007,8 @@
+             && command_line.rpath == NULL)
+           {
+             lib_path = (const char *) getenv ("LD_RUN_PATH");
++            if ((lib_path) && (strlen (lib_path) == 0))
++                lib_path = NULL;
+             if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
+                                                     force))
+               break;
+@@ -1191,6 +1193,8 @@
+   rpath = command_line.rpath;
+   if (rpath == NULL)
+     rpath = (const char *) getenv ("LD_RUN_PATH");
++  if ((rpath) && (strlen (rpath) == 0))
++      rpath = NULL;
+   if (! (bfd_elf_size_dynamic_sections
+        (output_bfd, command_line.soname, rpath,
+         command_line.filter_shlib,
diff --git a/toolchain/binutils/2.18/110-arm-eabi-conf.patch b/toolchain/binutils/2.18/110-arm-eabi-conf.patch
new file mode 100644 (file)
index 0000000..04e19be
--- /dev/null
@@ -0,0 +1,24 @@
+diff -u binutils-2.17.50.0.17.oorig/configure binutils-2.17.50.0.17/configure
+--- binutils-2.17.50.0.17.oorig/configure      2007-06-18 19:29:28.000000000 +0200
++++ binutils-2.17.50.0.17/configure    2007-06-25 09:58:36.000000000 +0200
+@@ -2224,7 +2224,7 @@
+   arm-*-elf* | strongarm-*-elf* | xscale-*-elf* | arm*-*-eabi* )
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     ;;
+-  arm*-*-linux-gnueabi)
++  arm*-*-linux-gnueabi | arm*-*-linux-uclibcgnueabi)
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     noconfigdirs="$noconfigdirs target-libjava target-libobjc"
+     ;;
+diff -u binutils-2.17.50.0.17.oorig/configure.ac binutils-2.17.50.0.17/configure.ac
+--- binutils-2.17.50.0.17.oorig/configure.ac   2007-06-18 19:29:28.000000000 +0200
++++ binutils-2.17.50.0.17/configure.ac 2007-06-25 09:58:36.000000000 +0200
+@@ -513,7 +513,7 @@
+   arm-*-elf* | strongarm-*-elf* | xscale-*-elf* | arm*-*-eabi* )
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     ;;
+-  arm*-*-linux-gnueabi)
++  arm*-*-linux-gnueabi | arm*-*-linux-uclibcgnueabi)
+     noconfigdirs="$noconfigdirs target-libffi target-qthreads"
+     noconfigdirs="$noconfigdirs target-libjava target-libobjc"
+     ;;
diff --git a/toolchain/binutils/2.18/300-001_ld_makefile_patch.patch b/toolchain/binutils/2.18/300-001_ld_makefile_patch.patch
new file mode 100644 (file)
index 0000000..5cb0f61
--- /dev/null
@@ -0,0 +1,24 @@
+diff -u binutils-2.17.50.0.17.oorig/ld/Makefile.am binutils-2.17.50.0.17/ld/Makefile.am
+--- binutils-2.17.50.0.17.oorig/ld/Makefile.am 2007-06-18 19:29:29.000000000 +0200
++++ binutils-2.17.50.0.17/ld/Makefile.am       2007-06-25 10:00:36.000000000 +0200
+@@ -18,7 +18,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+diff -u binutils-2.17.50.0.17.oorig/ld/Makefile.in binutils-2.17.50.0.17/ld/Makefile.in
+--- binutils-2.17.50.0.17.oorig/ld/Makefile.in 2007-06-18 19:29:29.000000000 +0200
++++ binutils-2.17.50.0.17/ld/Makefile.in       2007-06-25 10:00:36.000000000 +0200
+@@ -287,7 +287,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ BASEDIR = $(srcdir)/..
+ BFDDIR = $(BASEDIR)/bfd
+ INCDIR = $(BASEDIR)/include
diff --git a/toolchain/binutils/2.18/300-012_check_ldrunpath_length.patch b/toolchain/binutils/2.18/300-012_check_ldrunpath_length.patch
new file mode 100644 (file)
index 0000000..6e80921
--- /dev/null
@@ -0,0 +1,21 @@
+diff -u binutils-2.17.50.0.17.oorig/ld/emultempl/elf32.em binutils-2.17.50.0.17/ld/emultempl/elf32.em
+--- binutils-2.17.50.0.17.oorig/ld/emultempl/elf32.em  2007-06-18 19:31:40.000000000 +0200
++++ binutils-2.17.50.0.17/ld/emultempl/elf32.em        2007-06-25 10:01:25.000000000 +0200
+@@ -1007,6 +1007,8 @@
+             && command_line.rpath == NULL)
+           {
+             lib_path = (const char *) getenv ("LD_RUN_PATH");
++            if ((lib_path) && (strlen (lib_path) == 0))
++                lib_path = NULL;
+             if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
+                                                     force))
+               break;
+@@ -1191,6 +1193,8 @@
+   rpath = command_line.rpath;
+   if (rpath == NULL)
+     rpath = (const char *) getenv ("LD_RUN_PATH");
++  if ((rpath) && (strlen (rpath) == 0))
++      rpath = NULL;
+   if (! (bfd_elf_size_dynamic_sections
+        (output_bfd, command_line.soname, rpath,
+         command_line.filter_shlib,
index d8fb61d5bf982f6232ce6542ff21c6f88a66ffeb..2fac4e97e16ed7cc1b071f5237fa2e8de2983b47 100644 (file)
@@ -21,7 +21,7 @@ choice
                bool "binutils 2.15.94.0.2.2"
 
        config BR2_BINUTILS_VERSION_2_16_1
-               depends !BR2_avr32 && !BR2_nios2
+               depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
                bool "binutils 2.16.1"
 
        config BR2_BINUTILS_VERSION_2_16_90_0_3
@@ -37,11 +37,11 @@ choice
                bool "binutils 2.16.91.0.6"
 
        config BR2_BINUTILS_VERSION_2_16_91_0_7
-               depends !BR2_avr32 && !BR2_nios2
+               depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
                bool "binutils 2.16.91.0.7"
 
        config BR2_BINUTILS_VERSION_2_17
-               depends !BR2_nios2
+               depends !BR2_nios2 && BR2_DEPRECATED
                bool "binutils 2.17"
 
        config BR2_BINUTILS_VERSION_2_17_50_0_2
@@ -81,7 +81,7 @@ choice
                bool "binutils 2.17.50.0.10"
 
        config BR2_BINUTILS_VERSION_2_17_50_0_12
-               depends !BR2_avr32 && !BR2_nios2
+               depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
                bool "binutils 2.17.50.0.12"
 
        config BR2_BINUTILS_VERSION_2_17_50_0_14
@@ -93,8 +93,16 @@ choice
                bool "binutils 2.17.50.0.16"
 
        config BR2_BINUTILS_VERSION_2_17_50_0_17
-               depends !BR2_avr32 && !BR2_nios2
+               depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
                bool "binutils 2.17.50.0.17"
+
+       config BR2_BINUTILS_VERSION_2_18
+               depends !BR2_avr32 && !BR2_nios2
+               bool "binutils 2.18"
+
+       config BR2_BINUTILS_VERSION_2_18_50_0_1
+               depends !BR2_avr32 && !BR2_nios2
+               bool "binutils 2.18.50.0.1"
 endchoice
 
 config BR2_BINUTILS_VERSION
@@ -121,9 +129,12 @@ config BR2_BINUTILS_VERSION
        default "2.17.50.0.14"    if BR2_BINUTILS_VERSION_2_17_50_0_14
        default "2.17.50.0.16"    if BR2_BINUTILS_VERSION_2_17_50_0_16
        default "2.17.50.0.17"    if BR2_BINUTILS_VERSION_2_17_50_0_17
+       default "2.18"            if BR2_BINUTILS_VERSION_2_18
+       default "2.18.50.0.1"     if BR2_BINUTILS_VERSION_2_18_50_0_1
 
 config BR2_EXTRA_BINUTILS_CONFIG_OPTIONS
        string "Additional binutils options"
        default ""
        help
-         Any additional binutils options you may want to include ...
+         Any additional binutils options you may want to include.
+
index 1e8efca5405fd5080dbfab4b12a11efd5cdbd934..d0546d457359fe63364536dd0806f6da76360fb0 100644 (file)
@@ -9,6 +9,9 @@ BINUTILS_VERSION:=$(strip $(subst ",, $(BR2_BINUTILS_VERSION)))
 EXTRA_BINUTILS_CONFIG_OPTIONS=$(strip $(subst ",, $(BR2_EXTRA_BINUTILS_CONFIG_OPTIONS)))
 #"))
 BINUTILS_SITE:=ftp://ftp.kernel.org/pub/linux/devel/binutils
+ifeq ($(BINUTILS_VERSION),2.18)
+BINUTILS_SITE:=ftp://ftp.gnu.org/gnu/binutils/
+endif
 ifeq ($(BINUTILS_VERSION),2.17)
 BINUTILS_SITE:=ftp://ftp.gnu.org/gnu/binutils/
 endif