qt5location: install examples to target
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Tue, 12 Jun 2018 12:31:59 +0000 (08:31 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 12:35:05 +0000 (14:35 +0200)
When BR2_PACKAGE_QT5BASE_EXAMPLES is set, the examples for this module
are installed in the staging directory but they are not shipped to the
target.

This commit copies the examples `location' and `positioning' from the
staging directory to the target.

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5location/qt5location.mk

index 05cd1168a37c4a60bafbe1422cbe4a1f8b1de49c..18253e9965342001a8a5c86085bcaab4fb117124 100644 (file)
@@ -44,6 +44,12 @@ define QT5LOCATION_INSTALL_TARGET_LOCATION
        cp -dpf $(STAGING_DIR)/usr/lib/libQt5Location.so.* $(TARGET_DIR)/usr/lib
        cp -dpfr $(STAGING_DIR)/usr/lib/qt/plugins/geoservices $(TARGET_DIR)/usr/lib/qt/plugins/
 endef
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5LOCATION_INSTALL_TARGET_EXAMPLES
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/location $(TARGET_DIR)/usr/lib/qt/examples/
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/positioning $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
 endif
 
 define QT5LOCATION_INSTALL_TARGET_POSITION
@@ -55,6 +61,7 @@ define QT5LOCATION_INSTALL_TARGET_CMDS
        $(QT5LOCATION_INSTALL_TARGET_POSITION)
        $(QT5LOCATION_INSTALL_TARGET_LOCATION)
        $(QT5LOCATION_INSTALL_TARGET_QMLS)
+       $(QT5LOCATION_INSTALL_TARGET_EXAMPLES)
 endef
 
 $(eval $(generic-package))