package/optee-benchmark: new package
authorEtienne Carriere <etienne.carriere@linaro.org>
Wed, 30 Jan 2019 10:47:27 +0000 (11:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Feb 2019 22:01:11 +0000 (23:01 +0100)
OP-TEE performance benchmark tools for the OP-TEE project.

This packages generates embedded Linux based OS materials used
to retrieve execution timing information on invocation of the
OP-TEE secure services.

It is added next to the OP-TEE client package in BR configuration.

This change references in Buildroot the today's latest OP-TEE
revision release tagged 3.4.0.

Signed-off-by: Etienne Carriere <etienne.carriere@linaro.org>
[Thomas:
 - drop version selection
 - propagate the dependency of optee-client]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/optee-benchmark/Config.in [new file with mode: 0644]
package/optee-benchmark/optee-benchmark.hash [new file with mode: 0644]
package/optee-benchmark/optee-benchmark.mk [new file with mode: 0644]

index ea307ddcbbabd3e8823014641dda8f258e189ab6..44de17aba17e84a7e781cd4d928beba33f4e37b7 100644 (file)
@@ -689,6 +689,7 @@ F:  package/szip/
 
 N:     Etienne Carriere <etienne.carriere@linaro.org>
 F:     boot/optee-os/
+F:     package/optee-benchmark/
 F:     package/optee-client/
 F:     package/optee-examples/
 F:     package/optee-test/
index cb81180faae6bff19e357a33466767688016128c..420e6e95a38931fc5cc5dfd49096494bf2a6215f 100644 (file)
@@ -2079,6 +2079,7 @@ endmenu
 
 menu "Security"
        source "package/checkpolicy/Config.in"
+       source "package/optee-benchmark/Config.in"
        source "package/optee-client/Config.in"
        source "package/optee-examples/Config.in"
        source "package/optee-test/Config.in"
diff --git a/package/optee-benchmark/Config.in b/package/optee-benchmark/Config.in
new file mode 100644 (file)
index 0000000..0e36549
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_OPTEE_BENCHMARK
+       bool "optee-benchmark"
+       depends on !BR2_STATIC_LIBS # optee-client
+       select BR2_PACKAGE_OPTEE_CLIENT
+       select BR2_PACKAGE_LIBYAML
+       help
+         Enable the OP-TEE benchmark package that brings facilities
+         for profiling traversal and execution timings when
+         invoking OP-TEE. OP-TEE benchmark is a component delivered
+         by the OP-TEE project.
+
+         http://github.com/linaro-swg/optee_benchmark
+
+comment "optee-benchmark needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/optee-benchmark/optee-benchmark.hash b/package/optee-benchmark/optee-benchmark.hash
new file mode 100644 (file)
index 0000000..c3c41b6
--- /dev/null
@@ -0,0 +1,2 @@
+# From https://github.com/linaro-swg/optee_benchmark/archive/3.4.0.tar.gz
+sha256 e5e868a06a9dcc8cc444b3e72c65f57670b0811091be62edbe0d03d13c75e716 optee-benchmark-3.4.0.tar.gz
diff --git a/package/optee-benchmark/optee-benchmark.mk b/package/optee-benchmark/optee-benchmark.mk
new file mode 100644 (file)
index 0000000..4ebab44
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# optee-benchmark
+#
+################################################################################
+
+OPTEE_BENCHMARK_VERSION = 3.4.0
+OPTEE_BENCHMARK_SITE = $(call github,linaro-swg,optee_benchmark,$(OPTEE_BENCHMARK_VERSION))
+OPTEE_BENCHMARK_LICENSE = BSD-2-Clause
+
+OPTEE_BENCHMARK_DEPENDENCIES = optee-client libyaml
+
+$(eval $(cmake-package))