package/botan: add optional dependency to xz
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 18 Aug 2018 23:30:52 +0000 (01:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 20 Aug 2018 21:32:58 +0000 (23:32 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/botan/botan.mk

index 984ecdc039f7c9d37ab523627bbda74076633fd1..eb817f62d9f9ca9501095b72715ca9020dfbec16 100644 (file)
@@ -60,6 +60,11 @@ BOTAN_DEPENDENCIES += sqlite
 BOTAN_CONF_OPTS += --with-sqlite
 endif
 
+ifeq ($(BR2_PACKAGE_XZ),y)
+BOTAN_DEPENDENCIES += xz
+BOTAN_CONF_OPTS += --with-lzma
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 BOTAN_DEPENDENCIES += zlib
 BOTAN_CONF_OPTS += --with-zlib