boot/barebox: license files hashes only valid for latest version
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 5 Feb 2020 14:48:41 +0000 (15:48 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 6 Feb 2020 18:19:23 +0000 (19:19 +0100)
We can only know the details of the license files for known versions.  For
custom, older or newer versions, the license files may change, or may be
moved around.

So, do for Barebox as was done for ATF, linux, and linux-headers, and
only define the list of license files for the latest version.

Add the hash for that license file, and align hashes to the new spacing
convention.

Reported-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Markus Mayer <mmayer@broadcom.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/barebox/barebox.hash
boot/barebox/barebox.mk

index 42561ea5715f85921b63e7efa4308e70cbe73d3d..64fec919b8b2fa6d42c38651c3467172f599fa77 100644 (file)
@@ -1,5 +1,8 @@
 # From https://www.barebox.org/download/barebox-2019.12.0.tar.bz2.md5
-md5 2d25158ccffaa843c9e4943bbe820ce2 barebox-2019.12.0.tar.bz2
+md5  2d25158ccffaa843c9e4943bbe820ce2  barebox-2019.12.0.tar.bz2
 
 # Locally calculated
-sha256 fb77afc5c1a9783b8e1a9bb6c617973f5c0ed4c6f8e079f96cb7e7e0818a7a90 barebox-2019.12.0.tar.bz2
+sha256  fb77afc5c1a9783b8e1a9bb6c617973f5c0ed4c6f8e079f96cb7e7e0818a7a90  barebox-2019.12.0.tar.bz2
+
+# License files, locally computed
+sha256  ab1122aa9f9073ad1ec824edcd970b16a6a7881a34a18fd56c080debb2dca5d4  COPYING
index 52178d89c8462c904e66cb46d17fbf16b4d4676f..f11f9950d15bf2e149289aa174ee489404d687dd 100644 (file)
@@ -33,7 +33,9 @@ endif
 
 $(1)_DEPENDENCIES = host-lzop
 $(1)_LICENSE = GPL-2.0 with exceptions
+ifeq ($(BR2_TARGET_BAREBOX_LATEST_VERSION),y)
 $(1)_LICENSE_FILES = COPYING
+endif
 
 $(1)_CUSTOM_EMBEDDED_ENV_PATH = $$(call qstrip,$$(BR2_TARGET_$(1)_CUSTOM_EMBEDDED_ENV_PATH))