package/runc: convert to golang infrastructure
authorAngelo Compagnucci <angelo@amarulasolutions.com>
Sat, 31 Mar 2018 13:27:33 +0000 (15:27 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 31 Mar 2018 17:57:31 +0000 (19:57 +0200)
Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/runc/runc.mk

index fb3fec20f55945ee312d69f71c7a63e31ea40e39..f1586f32b2848b6a83bf946bae85dfadd23fcab9 100644 (file)
@@ -9,42 +9,15 @@ RUNC_SITE = $(call github,opencontainers,runc,$(RUNC_VERSION))
 RUNC_LICENSE = Apache-2.0
 RUNC_LICENSE_FILES = LICENSE
 
-RUNC_DEPENDENCIES = host-go
+RUNC_WORKSPACE = Godeps/_workspace
 
-RUNC_GOPATH = "$(@D)/Godeps/_workspace"
-RUNC_MAKE_ENV = $(HOST_GO_TARGET_ENV) \
-       CGO_ENABLED=1 \
-       GOBIN="$(@D)/bin" \
-       GOPATH="$(RUNC_GOPATH)" \
-       PATH=$(BR_PATH)
+RUNC_LDFLAGS = -X main.gitCommit=$(RUNC_VERSION)
 
-RUNC_GLDFLAGS = \
-       -X main.gitCommit=$(RUNC_VERSION)
-
-ifeq ($(BR2_STATIC_LIBS),y)
-RUNC_GLDFLAGS += -extldflags '-static'
-endif
-
-RUNC_GOTAGS = cgo static_build
+RUNC_TAGS = cgo static_build
 
 ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
-RUNC_GOTAGS += seccomp
+RUNC_TAGS += seccomp
 RUNC_DEPENDENCIES += libseccomp host-pkgconf
 endif
 
-define RUNC_CONFIGURE_CMDS
-       mkdir -p $(RUNC_GOPATH)/src/github.com/opencontainers
-       ln -s $(@D) $(RUNC_GOPATH)/src/github.com/opencontainers/runc
-endef
-
-define RUNC_BUILD_CMDS
-       cd $(@D) && $(RUNC_MAKE_ENV) $(HOST_DIR)/bin/go \
-               build -v -o $(@D)/bin/runc \
-               -tags "$(RUNC_GOTAGS)" -ldflags "$(RUNC_GLDFLAGS)" .
-endef
-
-define RUNC_INSTALL_TARGET_CMDS
-       $(INSTALL) -D -m 0755 $(@D)/bin/runc $(TARGET_DIR)/usr/bin/runc
-endef
-
-$(eval $(generic-package))
+$(eval $(golang-package))