qt5location: copy PositioningQuick.so* for QtQuick
authorAlexander 'z33ky' Hirsch <1zeeky@gmail.com>
Tue, 16 Oct 2018 22:58:55 +0000 (00:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 17 Oct 2018 19:47:01 +0000 (21:47 +0200)
The Location module for QtQuick depends on this library, which was not
being copied in the build rule.

Signed-off-by: Alexander 'z33ky' Hirsch <1zeeky@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5location/qt5location.mk

index 18253e9965342001a8a5c86085bcaab4fb117124..da0aad796114a9eccb8544d2b9bfab9893a372fc 100644 (file)
@@ -44,6 +44,11 @@ define QT5LOCATION_INSTALL_TARGET_LOCATION
        cp -dpf $(STAGING_DIR)/usr/lib/libQt5Location.so.* $(TARGET_DIR)/usr/lib
        cp -dpfr $(STAGING_DIR)/usr/lib/qt/plugins/geoservices $(TARGET_DIR)/usr/lib/qt/plugins/
 endef
+ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST),y)
+define QT5LOCATION_INSTALL_TARGET_POSITION_QUICK
+       cp -dpf $(STAGING_DIR)/usr/lib/libQt5PositioningQuick.so.* $(TARGET_DIR)/usr/lib
+endef
+endif
 ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
 define QT5LOCATION_INSTALL_TARGET_EXAMPLES
        cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/location $(TARGET_DIR)/usr/lib/qt/examples/
@@ -59,6 +64,7 @@ endef
 
 define QT5LOCATION_INSTALL_TARGET_CMDS
        $(QT5LOCATION_INSTALL_TARGET_POSITION)
+       $(QT5LOCATION_INSTALL_TARGET_POSITION_QUICK)
        $(QT5LOCATION_INSTALL_TARGET_LOCATION)
        $(QT5LOCATION_INSTALL_TARGET_QMLS)
        $(QT5LOCATION_INSTALL_TARGET_EXAMPLES)