linux: Add Linux Kernel extensions menu
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Sat, 17 Sep 2011 20:22:51 +0000 (22:22 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 18 Sep 2011 20:59:20 +0000 (22:59 +0200)
Add a kernel sub-menu (called "Linux Kernel Extensions"), which makes
possible to patch it or tweak the kernel build step.

 * All linux/linux-ext-*.mk files will be read by the make process.
 * The menu can be customized in "linux/Config.ext.in".

[Peter: small fixes]
Signed-off-by: Benoit Mauduit <benoit.mauduit@openwide.fr>
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/Config.ext.in [new file with mode: 0644]
linux/Config.in
linux/linux.mk

diff --git a/linux/Config.ext.in b/linux/Config.ext.in
new file mode 100644 (file)
index 0000000..50e801d
--- /dev/null
@@ -0,0 +1,3 @@
+menu "Linux Kernel Extensions"
+
+endmenu
index 537cb54cc3a0c61d14a496653734c0b12c2358a0..56552867fb721437b1d44913c8732a738e762d72 100644 (file)
@@ -176,6 +176,10 @@ config BR2_LINUX_KERNEL_INSTALL_TARGET
          /boot in the target root filesystem, as is typically done on
          x86/x86_64 systems.
 
+
+# Linux extensions
+source "linux/Config.ext.in"
+
 endif # BR2_LINUX_KERNEL
 
 endmenu
index d289b284270967eb9f344669862d44efbd4b4036..f249d967011716608425850fac058116bfad0cdb 100644 (file)
@@ -177,6 +177,8 @@ define LINUX_INSTALL_TARGET_CMDS
        fi
 endef
 
+include linux/linux-ext-*.mk
+
 $(eval $(call GENTARGETS,,linux))
 
 linux-menuconfig linux-xconfig linux-gconfig linux-nconfig linux26-menuconfig linux26-xconfig linux26-gconfig linux26-nconfig: dirs $(LINUX_DIR)/.stamp_configured