gst1-plugins-bad: update configure options
authorPeter Seiderer <ps.report@gmx.net>
Thu, 15 Oct 2015 19:42:43 +0000 (21:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 21 Oct 2015 21:36:37 +0000 (23:36 +0200)
- add new onvif option
- add new dtls option
- add new openh264 option
- add new x265 option
- removed real plugin option
- add new rtp option
- remove always disabled legacy options: directdraw, osx_video,
  quicktime and mythtv
- add '--disable-bs2b' and '--disable-libde265' to options
  which require currently unpackaged libraries
- add '--disable-gtk3' and '--disable-qt'

[Thomas: improve wording of Config.in.legacy option.]

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index a452bf5a98a61cce8c599351e63af9eb8b43899a..c5b8223cf1767621754bfb6d80ced801ac366619 100644 (file)
@@ -107,6 +107,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2015.11"
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_REAL
+       bool "gst1-plugins-bad real plugin has been removed"
+       select BR2_LEGACY
+       help
+         The real plugin from GStreamer 1 bad plugins has been
+         removed.
+
 config BR2_PACKAGE_MEDIA_CTL
        bool "media-ctl package has been removed"
        select BR2_LEGACY
index a7788439bfeae24ab7786ee70507c23e7abe0983..a28243b8f320c904dc4055331c0fb1e11eb9272b 100644 (file)
@@ -219,6 +219,12 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DEBUGUTILS
        help
          Collection of elements that may or may not be useful for debugging
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DTLS
+       bool "dtls"
+       select BR2_PACKAGE_OPENSSL
+       help
+         DTLS plugin
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DVBSUBOVERLAY
        bool "dvdsuboverlay"
        help
@@ -347,6 +353,9 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MXF
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_NUVDEMUX
        bool "nuvdemux"
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ONVIF
+       bool "onvif"
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PATCHDETECT
        bool "patchdetect"
 
@@ -365,14 +374,14 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RAWPARSE
        help
          Parses byte streams into raw frames
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_REAL
-       bool "real"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_REMOVESILENCE
        bool "removesilence"
        help
          Removes silence from an audio stream
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RTP
+       bool "rtp"
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI
        bool "sdi"
 
@@ -574,6 +583,10 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPENCV
 comment "opencv plugin needs OpenCV-2.4"
        depends on !BR2_PACKAGE_OPENCV
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPENH264
+       bool "openh264"
+       select BR2_PACKAGE_LIBOPENH264
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPUS
        bool "opus"
        select BR2_PACKAGE_OPUS
@@ -620,4 +633,9 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_HLS
        help
          Fragmented streaming plugins
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_X265
+       bool "x265"
+       help
+         x265 plugin
+
 endif
index 2fbd49bc5beb241dbe19f075bb8d77535b6d51b1..fe5f2427cf52f7b8128b1cef06cb228ff18d7566 100644 (file)
@@ -22,12 +22,10 @@ GST1_PLUGINS_BAD_CONF_OPTS = \
        --disable-directsound \
        --disable-wsapi \
        --disable-direct3d \
-       --disable-directdraw \
        --disable-direct3d9 \
        --disable-winks \
        --disable-android_media \
        --disable-apple_media \
-       --disable-osx_video \
        --disable-sdltest \
        --disable-wininet \
        --disable-acm
@@ -35,10 +33,10 @@ GST1_PLUGINS_BAD_CONF_OPTS = \
 # Options which require currently unpackaged libraries
 GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-avc \
-       --disable-quicktime \
        --disable-opensles \
        --disable-uvch264 \
        --disable-voamrwbenc \
+       --disable-bs2b \
        --disable-chromaprint \
        --disable-dash \
        --disable-dc1394 \
@@ -51,12 +49,12 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-kate \
        --disable-ladspa \
        --disable-lv2 \
+       --disable-libde265 \
        --disable-strp \
        --disable-linsys \
        --disable-modplug \
        --disable-mimic \
        --disable-mplex \
-       --disable-mythtv \
        --disable-nas \
        --disable-ofa \
        --disable-openal \
@@ -81,7 +79,9 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-spandsp \
        --disable-gsettings \
        --disable-sndio \
-       --disable-hls
+       --disable-hls \
+       --disable-gtk3 \
+       --disable-qt
 
 GST1_PLUGINS_BAD_DEPENDENCIES = gst1-plugins-base gstreamer1
 
@@ -261,6 +261,13 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-debugutils
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DTLS),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-dtls
+GST1_PLUGINS_BAD_DEPENDENCIES += openssl
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-dtls
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_DVBSUBOVERLAY),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-dvbsuboverlay
 else
@@ -431,6 +438,12 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-nuvdemux
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ONVIF),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-onvif
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-onvif
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_PATCHDETECT),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-patchdetect
 else
@@ -455,18 +468,18 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-rawparse
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_REAL),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-real
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-real
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_REMOVESILENCE),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-removesilence
 else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-removesilence
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RTP),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-rtp
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-rtp
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-sdi
 else
@@ -745,6 +758,12 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-hls
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_X265),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-x265
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-x265
+endif
+
 # Add GPL license if GPL licensed plugins enabled.
 ifeq ($(GST1_PLUGINS_BAD_HAS_GPL_LICENSE),y)
 GST1_PLUGINS_BAD_LICENSE += GPL