libgpgme: disable all tests
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 12 Jul 2014 13:08:01 +0000 (10:08 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Jul 2014 18:47:38 +0000 (20:47 +0200)
Disable all of the tests, including runtime that needs gnupg.
There's no longer --without configure options for them, it's now
--disable. Fixes:
http://autobuild.buildroot.net/results/eb1/eb1e06b1d99c441b6086c07ee04b084a61041dc7/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libgpgme/libgpgme.mk

index c06d7131e57a6bdd5bf54c439619c1cddebcd5d3..43d748409adb1a2ccf362403f947521a925fd7e5 100644 (file)
@@ -16,9 +16,10 @@ LIBGPGME_DEPENDENCIES = libassuan libgpg-error
 LIBGPGME_CONF_OPT = --with-gpg=/usr/bin/gpg \
        --with-gpg-error-prefix=$(STAGING_DIR)/usr \
        --with-libassuan-prefix=$(STAGING_DIR)/usr \
-       --without-gpgsm \
-       --without-gpgconf \
-       --without-g13
+       --disable-gpgsm-test \
+       --disable-gpgconf-test \
+       --disable-g13-test \
+       --disable-gpg-test
 
 # Handle argp-standalone or it errors out during build
 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE)$(BR2_TOOLCHAIN_USES_UCLIBC),yy)