external toolchain: do not copy useless symbolic links
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 16 Jul 2009 22:25:35 +0000 (00:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 17 Jul 2009 06:46:43 +0000 (08:46 +0200)
Do not copy .so symbolic links to target when not needed. Only copy
.so.X symbolic links and the library itself.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/external-toolchain/ext-tool.mk

index 0e1deb620900d8fa373429969ac2d39a36608614..6df48f0b0b6a29dfd59734b383447d5837489fa3 100644 (file)
@@ -46,7 +46,7 @@ copy_toolchain_lib_root = \
        STRIP="$(strip $4)"; \
  \
        LIB_DIR="$${SYSROOT_DIR}/lib" ; \
-       for FILE in `find $${LIB_DIR} -maxdepth 1 -type l -name "$${LIB}*"`; do \
+       for FILE in `find $${LIB_DIR} -maxdepth 1 -name "$${LIB}.*"`; do \
                LIB=`basename $${FILE}`; \
                while test \! -z "$${LIB}"; do \
                        rm -fr $(TARGET_DIR)$${DST}/$${LIB}; \