gst1-plugins-good: add libvpx support
authorSpenser Gilliland <spenser@gillilanding.com>
Thu, 20 Jun 2013 22:07:42 +0000 (17:07 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 Jun 2013 14:05:37 +0000 (16:05 +0200)
adds libvpx support to gst1-plugins-good

Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst1-plugins-good/Config.in
package/multimedia/gst1-plugins-good/gst1-plugins-good.mk

index 9b7eba0f06d009bc0dcfa808d9f0a4045bee9d82..e5795394835f2156b1f87c42a21ac25e1606e5bb 100644 (file)
@@ -317,6 +317,10 @@ config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_VPX
        help
          VP8 plugin
 
+config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_VPX
+       bool "vpx (webm)"
+       select BR2_PACKAGE_LIBVPX
+
 config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_WAVPACK
        bool "wavpack (*.wv audio)"
        select BR2_PACKAGE_WAVPACK
index f177ed1b4cbf7a990d312451f43889420b03bf79..1e6d39b30424fd1797e25e390e57480ea6bf1874 100644 (file)
@@ -380,6 +380,13 @@ else
 GST1_PLUGINS_GOOD_CONF_OPT += --disable-speex
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_VPX),y)
+GST1_PLUGINS_GOOD_CONF_OPT += --enable-vpx
+GST1_PLUGINS_GOOD_DEPENDENCIES += libvpx
+else
+GST1_PLUGINS_GOOD_CONF_OPT += --disable-vpx
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_WAVPACK),y)
 GST1_PLUGINS_GOOD_CONF_OPT += --enable-wavpack
 GST1_PLUGINS_GOOD_DEPENDENCIES += wavpack