package/libcpprestsdk: needs locale
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 14 Mar 2020 22:20:27 +0000 (23:20 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 15 Mar 2020 21:47:10 +0000 (22:47 +0100)
locale_t is unconditionally used since version 2.3.0 and
https://github.com/microsoft/cpprestsdk/commit/814caa4c0a80ef223535446a274146bf46a5ef2b

Fixes:
 - No autobuilder failures

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libcpprestsdk/Config.in
package/libcpprestsdk/libcpprestsdk.mk

index a07159b124216de0274a9aec2418bd16624c920b..01ebc6aa7f9af8ba5d9a9f4e261da196e91b1773 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_LIBCPPRESTSDK
        bool "libcpprestsdk"
+       depends on BR2_ENABLE_LOCALE
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR # boost
        depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735 # exception_ptr
@@ -22,10 +23,10 @@ config BR2_PACKAGE_LIBCPPRESTSDK
 
          https://github.com/Microsoft/cpprestsdk
 
-comment "libcpprestsdk needs a toolchain w/ NPTL, C++, wchar"
+comment "libcpprestsdk needs a toolchain w/ NPTL, C++, wchar, locale"
        depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL || \
                !BR2_INSTALL_LIBSTDCPP || \
-               !BR2_USE_WCHAR
+               !BR2_USE_WCHAR || !BR2_ENABLE_LOCALE
 
 comment "libcpprestsdk needs exception_ptr"
        depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735
index 8404b5096c65b0ffaac6202ab467f7084c751dec..e746f22b1b2d86e462a34fc3cedf49276e236a41 100644 (file)
@@ -10,7 +10,7 @@ LIBCPPRESTSDK_LICENSE = MIT
 LIBCPPRESTSDK_LICENSE_FILES = license.txt
 LIBCPPRESTSDK_SUBDIR = Release
 LIBCPPRESTSDK_INSTALL_STAGING = YES
-LIBCPPRESTSDK_DEPENDENCIES += host-pkgconf boost openssl zlib
+LIBCPPRESTSDK_DEPENDENCIES += host-pkgconf boost openssl
 LIBCPPRESTSDK_CONF_OPTS = -DWERROR=OFF -DBUILD_SAMPLES=OFF
 
 ifeq ($(BR2_STATIC_LIBS),y)