package/gst1-validate: allow to use host-python3 and target python3
authorTitouan Christophe <titouan.christophe@railnova.eu>
Mon, 28 Oct 2019 11:15:56 +0000 (12:15 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 29 Oct 2019 08:58:37 +0000 (09:58 +0100)
Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/gstreamer1/gst1-validate/Config.in
package/gstreamer1/gst1-validate/gst1-validate.mk

index 2022d38d99bae472d17b936d36fe136a650f5366..63bce613edb52ddb00c4d804491de748d98e5091 100644 (file)
@@ -1,9 +1,10 @@
 config BR2_PACKAGE_GST1_VALIDATE
        bool "gst1-validate"
-       depends on BR2_PACKAGE_PYTHON
+       depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
        select BR2_PACKAGE_GST1_PLUGINS_BASE
        select BR2_PACKAGE_JSON_GLIB
-       select BR2_PACKAGE_PYTHON_PYEXPAT
+       select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3
        # cairo is autodetected but needs PNG support
        select BR2_PACKAGE_CAIRO_PNG if BR2_PACKAGE_CAIRO
        help
@@ -15,3 +16,4 @@ config BR2_PACKAGE_GST1_VALIDATE
 
 comment "gst1-validate depends on python"
        depends on !BR2_PACKAGE_PYTHON
+       depends on !BR2_PACKAGE_PYTHON3
index da38aeb497aac35b8bf339afe55dff0b0d8ede6b..e9522e1568b4eb507a7edda4ef1b25fea0f249b7 100644 (file)
@@ -14,10 +14,14 @@ GST1_VALIDATE_DEPENDENCIES = \
        gstreamer1 \
        gst1-plugins-base \
        json-glib \
-       host-python \
-       python \
        $(if $(BR2_PACKAGE_CAIRO),cairo)
 
+ifeq ($(BR2_PACKAGE_PYTHON3),y)
+GST1_VALIDATE_DEPENDENCIES += host-python3 python3
+else
+GST1_VALIDATE_DEPENDENCIES += host-python python
+endif
+
 GST1_VALIDATE_CONF_OPTS += --disable-sphinx-doc
 
 $(eval $(autotools-package))