poppler: qt5 support needs c++11 (since Qt5.7)
authorNaumann Andreas <ANaumann@ultratronik.de>
Sat, 11 Feb 2017 11:05:31 +0000 (12:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Feb 2017 14:19:57 +0000 (15:19 +0100)
Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/poppler/poppler.mk

index 022c2c5e99b8e2a5cd6129c991b85d6213f554be..fda8284507cb63ae1286cb9feb19a0a6462bb5e9 100644 (file)
@@ -90,6 +90,10 @@ endif
 ifeq ($(BR2_PACKAGE_POPPLER_QT5),y)
 POPPLER_DEPENDENCIES += qt5base
 POPPLER_CONF_OPTS += --enable-poppler-qt5
+# since Qt5.7.x c++11 is needed (LTS Qt5.6.x is the last one without this requirement)
+ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST),y)
+POPPLER_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
+endif
 else
 POPPLER_CONF_OPTS += --disable-poppler-qt5
 endif