dtc: rename patches to new convention
authorPeter Seiderer <ps.report@gmx.net>
Tue, 13 Jan 2015 19:40:02 +0000 (20:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Jan 2015 19:40:39 +0000 (20:40 +0100)
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dtc/0001-separate-lib-install.patch [new file with mode: 0644]
package/dtc/0002-extra-cflags.patch [new file with mode: 0644]
package/dtc/dtc-extra_cflags.patch [deleted file]
package/dtc/dtc-separate-lib-install.patch [deleted file]

diff --git a/package/dtc/0001-separate-lib-install.patch b/package/dtc/0001-separate-lib-install.patch
new file mode 100644 (file)
index 0000000..c86d587
--- /dev/null
@@ -0,0 +1,28 @@
+Makefile: add a rule to only install libfdt
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+
+---
+Patch not sent upstream.
+
+It's really specific to buildroot, and is probably not
+good (aka generic) enough to be pushed upstream.
+
+diff --git a/Makefile b/Makefile
+index 1169e6c..39e7190 100644
+--- a/Makefile
++++ b/Makefile
+@@ -160,10 +160,12 @@ endif
+ # intermediate target and building them again "for real"
+ .SECONDARY: $(DTC_GEN_SRCS) $(CONVERT_GEN_SRCS)
+-install: all $(SCRIPTS)
++install: all $(SCRIPTS) libfdt_install
+       @$(VECHO) INSTALL
+       $(INSTALL) -d $(DESTDIR)$(BINDIR)
+       $(INSTALL) $(BIN) $(SCRIPTS) $(DESTDIR)$(BINDIR)
++
++libfdt_install: libfdt
+       $(INSTALL) -d $(DESTDIR)$(LIBDIR)
+       $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
+       ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
diff --git a/package/dtc/0002-extra-cflags.patch b/package/dtc/0002-extra-cflags.patch
new file mode 100644 (file)
index 0000000..51b7957
--- /dev/null
@@ -0,0 +1,32 @@
+Makefile: append the CFLAGS to existing ones
+
+Allow the user to pass custom CFLAGS (eg. optimisation flags).
+
+Do not use EXTRA_CFLAGS, append to existing CFLAGS with +=  (Arnout)
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+Cc: Arnout Vandecappelle <arnout@mind.be>
+
+---
+Patch not sent upstream.
+
+Although not specific to buildroot, I am not sure this is the best
+way to handle user-supplied CFLAGS.
+
+diff --git a/Makefile b/Makefile
+index 962f94eba661..bf6b317158cf 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,9 +16,10 @@ LOCAL_VERSION =
+ CONFIG_LOCALVERSION =
+ CPPFLAGS = -I libfdt -I .
+-WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
++WARNINGS = -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
+       -Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls
+-CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
++CFLAGS ?= -g -Os
++CFLAGS += -fPIC $(WARNINGS)
+ BISON = bison
+ LEX = flex
diff --git a/package/dtc/dtc-extra_cflags.patch b/package/dtc/dtc-extra_cflags.patch
deleted file mode 100644 (file)
index 51b7957..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-Makefile: append the CFLAGS to existing ones
-
-Allow the user to pass custom CFLAGS (eg. optimisation flags).
-
-Do not use EXTRA_CFLAGS, append to existing CFLAGS with +=  (Arnout)
-
-Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
-Cc: Arnout Vandecappelle <arnout@mind.be>
-
----
-Patch not sent upstream.
-
-Although not specific to buildroot, I am not sure this is the best
-way to handle user-supplied CFLAGS.
-
-diff --git a/Makefile b/Makefile
-index 962f94eba661..bf6b317158cf 100644
---- a/Makefile
-+++ b/Makefile
-@@ -16,9 +16,10 @@ LOCAL_VERSION =
- CONFIG_LOCALVERSION =
- CPPFLAGS = -I libfdt -I .
--WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
-+WARNINGS = -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
-       -Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls
--CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
-+CFLAGS ?= -g -Os
-+CFLAGS += -fPIC $(WARNINGS)
- BISON = bison
- LEX = flex
diff --git a/package/dtc/dtc-separate-lib-install.patch b/package/dtc/dtc-separate-lib-install.patch
deleted file mode 100644 (file)
index c86d587..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-Makefile: add a rule to only install libfdt
-
-Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
-
----
-Patch not sent upstream.
-
-It's really specific to buildroot, and is probably not
-good (aka generic) enough to be pushed upstream.
-
-diff --git a/Makefile b/Makefile
-index 1169e6c..39e7190 100644
---- a/Makefile
-+++ b/Makefile
-@@ -160,10 +160,12 @@ endif
- # intermediate target and building them again "for real"
- .SECONDARY: $(DTC_GEN_SRCS) $(CONVERT_GEN_SRCS)
--install: all $(SCRIPTS)
-+install: all $(SCRIPTS) libfdt_install
-       @$(VECHO) INSTALL
-       $(INSTALL) -d $(DESTDIR)$(BINDIR)
-       $(INSTALL) $(BIN) $(SCRIPTS) $(DESTDIR)$(BINDIR)
-+
-+libfdt_install: libfdt
-       $(INSTALL) -d $(DESTDIR)$(LIBDIR)
-       $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
-       ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)