Makefile: Don't export VERBOSE unless V=1 (for CMake)
authorCédric Marie <cedric.marie@openmailbox.org>
Tue, 23 Jun 2015 21:36:06 +0000 (23:36 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 24 Jun 2015 22:48:55 +0000 (00:48 +0200)
CMake verbose mode is based on VERBOSE environment variable.
* If VERBOSE is exported but empty, only "Dependee ... is newer than
depender ..." messages are shown.
* If VERBOSE is exported and set (whatever the value), all compilation
commands are shown.

VERBOSE is currently systematically exported by Buildroot, even if it
is empty, in the root Makefile, which implies that the "light" verbose
mode - with "Dependee ... is newer than depender ..." messages - is
always enabled.

VERBOSE should only be exported when V=1, which is the standard way to
enable verbose mode in Buildroot.

Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index d3f80c4b3f023d8b59a4a27b51f04a534de6f49a..8eb21d4c3820b2dfeb62e68b3d03fd413a8fe64f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -215,6 +215,7 @@ ifeq ($(KBUILD_VERBOSE),1)
 ifndef VERBOSE
   VERBOSE = 1
 endif
+export VERBOSE
 else
   quiet = quiet_
   Q = @
@@ -228,7 +229,7 @@ SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
 # kconfig uses CONFIG_SHELL
 CONFIG_SHELL := $(SHELL)
 
-export SHELL CONFIG_SHELL quiet Q KBUILD_VERBOSE VERBOSE
+export SHELL CONFIG_SHELL quiet Q KBUILD_VERBOSE
 
 ifndef HOSTAR
 HOSTAR := ar