libgtk3: ensure host version of pkg-config is used for native compilation
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 16 Oct 2014 11:52:57 +0000 (13:52 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 16 Oct 2014 11:52:57 +0000 (13:52 +0200)
This already was in Eric's submission, but I removed it when committing
while cleaning up.  The package infrastructure already passes the correct
pkg-config to use for cross compilation, but NOT for building native tools,
so we ended up using the target variant and got wrong libraries/headers.

Fixes:

http://autobuild.buildroot.net/results/e0c/e0c2623e2d400ce66963eae23f136c0158556b36/
http://autobuild.buildroot.net/results/5bf/5bf66b8d16a3ddded24827bf278ad24b55ded6e7/
http://autobuild.buildroot.net/results/75f/75f93cea8ab59f052ddefa51c0bfc14c3df47a60/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libgtk3/libgtk3.mk

index a9a681d9b3572331b494d0296668740e39bc9ecf..73b3e173e4ef2db1063aedaed750e22680dd41d9 100644 (file)
@@ -15,7 +15,8 @@ LIBGTK3_AUTORECONF = YES
 
 LIBGTK3_CONF_ENV = \
        ac_cv_path_GTK_UPDATE_ICON_CACHE=$(HOST_DIR)/usr/bin/gtk-update-icon-cache \
-       ac_cv_path_GDK_PIXBUF_CSOURCE=$(HOST_DIR)/usr/bin/gdk-pixbuf-csource
+       ac_cv_path_GDK_PIXBUF_CSOURCE=$(HOST_DIR)/usr/bin/gdk-pixbuf-csource \
+       PKG_CONFIG_FOR_BUILD=$(HOST_DIR)/usr/bin/pkgconf
 
 LIBGTK3_CONF_OPTS = --disable-glibtest \
        --enable-explicit-deps=no \