scons: expose SCONS variable, pointing to host scons
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 23 Jul 2012 21:22:26 +0000 (23:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 23 Jul 2012 21:23:27 +0000 (23:23 +0200)
Just like we have AUTOMAKE, AUTOCONF or QT_QMAKE, let the scons
package provide a SCONS variable that points to the scons host binary.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/scons/scons.mk

index 85dbfaff5781250b25e27580f4992e726c93b1e3..b81c4f4bec71c4df9555437e61c59918281448ed 100644 (file)
@@ -11,3 +11,6 @@ define HOST_SCONS_INSTALL_CMDS
 endef
 
 $(eval $(host-generic-package))
+
+# variables used by other packages
+SCONS = $(HOST_DIR)/usr/bin/scons