u-boot: cleanup arch handling
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 12 Jun 2008 07:27:48 +0000 (07:27 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 12 Jun 2008 07:27:48 +0000 (07:27 -0000)
Thanks to Hamish Moffatt.

target/u-boot/Makefile.in

index 541e71f7869c511c29cc709a437e123f6ad84d3f..fd74d41e03bfbca8e604aca96e88d9cf28dfc370 100644 (file)
@@ -12,7 +12,7 @@ U_BOOT_CAT:=$(BZCAT)
 U_BOOT_BIN:=u-boot.bin
 U_BOOT_TOOLS_BIN:=mkimage
 # u-boot still uses arch=ppc for powerpc
-U_BOOT_ARCH=$(shell echo $(KERNEL_ARCH)|$(HOST_SED_DIR)/bin/sed 's/powerpc/ppc/')
+U_BOOT_ARCH=$(KERNEL_ARCH:powerpc=ppc)
 
 ifneq ($(BR2_TARGET_U_BOOT_CONFIG_BOARD),)
 U_BOOT_INC_CONF_FILE:=$(U_BOOT_DIR)/include/configs/$(subst _config,,$(BR2_TARGET_U_BOOT_CONFIG_BOARD)).h