iftop: new package
authorBogdan Radulescu <bogdan@nimblex.net>
Mon, 21 Jan 2013 10:40:41 +0000 (10:40 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 21 Jan 2013 21:59:31 +0000 (22:59 +0100)
Added the iftop package which is really useful to see quickly
what uses the bandwidth on your machine.

[Peter: move to 'Networking applications', fix license]
Signed-off-by: Bogdan Radulescu <bogdan@nimblex.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/iftop/Config.in [new file with mode: 0644]
package/iftop/iftop.mk [new file with mode: 0644]

index 2bb3d295c98a3437ed970f804f0cd1c4794b42f2..39e2ec723d877942cf17ea6cee90b74a67f57f7a 100644 (file)
@@ -637,6 +637,7 @@ source "package/httping/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/ifplugd/Config.in"
 endif
+source "package/iftop/Config.in"
 source "package/igh-ethercat/Config.in"
 source "package/inadyn/Config.in"
 source "package/iperf/Config.in"
diff --git a/package/iftop/Config.in b/package/iftop/Config.in
new file mode 100644 (file)
index 0000000..99ea973
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_IFTOP
+       bool "iftop"
+       select BR2_PACKAGE_NCURSES
+       select BR2_PACKAGE_LIBPCAP
+       depends on BR2_INET_IPV6
+       help
+         iftop does for network usage what top(1) does for CPU usage.
+         It listens to network traffic on a named interface and displays
+         a table of current bandwidth usage by pairs of hosts. Handy for
+         answering the question "why is our ADSL link so slow?".
+
+         http://www.ex-parrot.com/pdw/iftop/
+
+comment "iftop requires IPv6 support in toolchain"
+       depends on !BR2_INET_IPV6
diff --git a/package/iftop/iftop.mk b/package/iftop/iftop.mk
new file mode 100644 (file)
index 0000000..f6f2af2
--- /dev/null
@@ -0,0 +1,15 @@
+#############################################################
+#
+# iftop
+#
+#############################################################
+
+IFTOP_VERSION = 1.0pre2
+IFTOP_SITE = http://www.ex-parrot.com/pdw/iftop/download/
+
+IFTOP_DEPENDENCIES = ncurses libpcap
+
+IFTOP_LICENSE = GPLv2+
+IFTOP_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))