package/openvpn: use make install instead of custom install step
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 31 Dec 2020 15:53:02 +0000 (16:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 31 Dec 2020 15:53:02 +0000 (16:53 +0100)
Commit 7105e65cd6b8f857bab54e4c0a8c57da776b0564 ("package/openvpn:
adds target install of systemd unit files") added the installation of
systemd unit files. But in fact, they can be installed by openvpn's
build system. It was simply not working due to the custom install step
implemented in openvpn.mk.

So instead, let's have the autotools-package infra call "make
install", which properly installs everything that's needed for
openvpn, including systemd units, but also plugins, etc.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/openvpn/openvpn.mk

index 741da9784ca9e68917bf88901f8f0a337fb45d40..53f332534d64fbae7461cb423fdea570bcbb74bf 100644 (file)
@@ -69,21 +69,9 @@ else
 OPENVPN_CONF_OPTS += --disable-systemd
 endif
 
-define OPENVPN_INSTALL_TARGET_CMDS
-       $(INSTALL) -m 755 $(@D)/src/openvpn/openvpn \
-               $(TARGET_DIR)/usr/sbin/openvpn
-endef
-
 define OPENVPN_INSTALL_INIT_SYSV
        $(INSTALL) -m 755 -D package/openvpn/S60openvpn \
                $(TARGET_DIR)/etc/init.d/S60openvpn
 endef
 
-define OPENVPN_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -D -m 0644 $(@D)/distro/systemd/openvpn-client@.service \
-               $(TARGET_DIR)/usr/lib/systemd/system/openvpn-client@.service
-       $(INSTALL) -D -m 0644 $(@D)/distro/systemd/openvpn-server@.service \
-               $(TARGET_DIR)/usr/lib/systemd/system/openvpn-server@.service
-endef
-
 $(eval $(autotools-package))