gst1-plugins-ugly: add mpg123 support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 25 Mar 2016 12:50:12 +0000 (09:50 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 26 Mar 2016 15:56:45 +0000 (16:56 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer1/gst1-plugins-ugly/Config.in
package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk

index fbcb128c22e7fd0b85838e63c3ef90726a2aed97..995835e41a07b6eb20ca0d1225356bba285e6618 100644 (file)
@@ -61,6 +61,12 @@ config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MAD
        help
          mp3 decoding based on the mad library
 
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MPG123
+       bool "mpg123 (*.mp3 audio)"
+       select BR2_PACKAGE_MPG123
+       help
+         mp3 decoding based on the mpg123 library
+
 config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MPEG2DEC
        bool "mpeg2dec"
        select BR2_PACKAGE_LIBMPEG2
index a45e6708d3c2e62210d2e51511a80eb786c84779..16cfef292a3ddee0a0747d3869ae0ad29ffc27fe 100644 (file)
@@ -81,6 +81,13 @@ else
 GST1_PLUGINS_UGLY_CONF_OPTS += --disable-mad
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MPG123),y)
+GST1_PLUGINS_UGLY_CONF_OPTS += --enable-mpg123
+GST1_PLUGINS_UGLY_DEPENDENCIES += mpg123
+else
+GST1_PLUGINS_UGLY_CONF_OPTS += --disable-mpg123
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MPEG2DEC),y)
 GST1_PLUGINS_UGLY_CONF_OPTS += --enable-mpeg2dec
 GST1_PLUGINS_UGLY_DEPENDENCIES += libmpeg2