package/htop: needs dynamic library
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 7 Jan 2021 06:48:55 +0000 (07:48 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 16 Jan 2021 22:01:42 +0000 (23:01 +0100)
htop unconditionally uses dlopen since version 3.0.3 and
https://github.com/htop-dev/htop/commit/2a9e8ca07475e61e74d7b6f0afd0a5fd272cb07f

Fixes:
 - http://autobuild.buildroot.org/results/2976729b0b95bf822c3095efbcf3f86d6c71874f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/htop/Config.in
package/htop/htop.mk

index 7bb0fe6e07e899a0cb502d5d8a315840e84faa3b..214a9a1c9957150a7d705f9144f9d38bb8d3b45c 100644 (file)
@@ -1,9 +1,14 @@
 config BR2_PACKAGE_HTOP
        bool "htop"
        depends on BR2_USE_MMU # fork()
+       depends on !BR2_STATIC_LIBS # dlopen()
        select BR2_PACKAGE_NCURSES
        help
          htop is an interactive text-mode process viewer for Linux.
          It aims to be a better top.
 
          https://htop.dev/
+
+comment "htop needs a toolchain w/ dynamic library"
+       depends on BR2_USE_MMU
+       depends on BR2_STATIC_LIBS
index bb6185a56d9b8c07c10f65bab1f57d395ed16745..25d1a9a129b6dfc7624383ceedca2918d5a293cf 100644 (file)
@@ -18,11 +18,4 @@ else
 HTOP_CONF_OPTS += --disable-unicode
 endif
 
-# ARC uses an old uClibc that needs dladdr() for backtrace support,
-# which doesn't work for static only scenario, so as a workaround, we
-# pretend that execinfo.h is not available.
-ifeq ($(BR2_arc)$(BR2_STATIC_LIBS),yy)
-HTOP_CONF_ENV += ac_cv_header_execinfo_h=no
-endif
-
 $(eval $(autotools-package))