package/php: fix date.timezone
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 12 Jun 2016 10:48:24 +0000 (12:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Jun 2016 16:38:39 +0000 (18:38 +0200)
In 5f37843a (php.ini: set date.timezone), the configured timezone was
used as the default for PHP.

However, BR2_TARGET_LOCALTIME is a string, so is quoted, so it is never
empty, so the check for emptynessnever matches.

Fix that by q-stripping the value before testing it. Note however that
we do not q-strip it before storing it in the php.ini file, because it
has to be q-stripped in there.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Floris Bos <bos@je-eigen-domein.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/php/php.mk

index 2997b1b7d1215ab8dbe5e74c280d38c763d53050..8dc70f091cb4d9851a238c40b534a8d7d9ba1374 100644 (file)
@@ -32,9 +32,10 @@ ifeq ($(BR2_STATIC_LIBS)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
 PHP_STATIC_LIBS += -lpthread
 endif
 
-ifeq ($(BR2_TARGET_LOCALTIME),)
+ifeq ($(call qstrip,$(BR2_TARGET_LOCALTIME)),)
 PHP_LOCALTIME = UTC
 else
+# Not q-stripping this value, as we need quotes in the php.ini file
 PHP_LOCALTIME = $(BR2_TARGET_LOCALTIME)
 endif