package/linknx: add optional log4cpp dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 20 Apr 2019 20:42:52 +0000 (22:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 21 Apr 2019 10:07:22 +0000 (12:07 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/linknx/linknx.mk

index e593feda3622157ef0f64516be3865c0f8e9ce59..15d4b5a1097e3b6d3df587fef03948c44f704cfe 100644 (file)
@@ -13,7 +13,6 @@ LINKNX_INSTALL_STAGING = YES
 LINKNX_AUTORECONF = YES
 LINKNX_CONF_OPTS = \
        --without-cppunit \
-       --without-log4cpp \
        --without-pth-test \
        --with-pth=$(STAGING_DIR)/usr \
        --disable-smtp
@@ -29,6 +28,13 @@ else
 LINKNX_CONF_OPTS += --without-libcurl
 endif
 
+ifeq ($(BR2_PACKAGE_LOG4CPP),y)
+LINKNX_CONF_OPTS += --with-log4cpp
+LINKNX_DEPENDENCIES += host-pkgconf log4cpp
+else
+LINKNX_CONF_OPTS += --without-log4cpp
+endif
+
 ifeq ($(BR2_PACKAGE_LUA),y)
 LINKNX_CONF_OPTS += --with-lua
 LINKNX_DEPENDENCIES += lua