package/libiio: fix python build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 5 Sep 2021 19:26:48 +0000 (21:26 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 11 Sep 2021 14:17:42 +0000 (16:17 +0200)
python bindings needs setuptools since bump to version 0.23 in commit
50b6d7d69f880e940d7c281c493a6a6694d6ebe3 and
https://github.com/analogdevicesinc/libiio/commit/21023a538b125dee966bf496dcad019ee20967bd

Fixes:
 - http://autobuild.buildroot.org/results/a26cce9760c75c44ebdcf21dfb4a69aad5702de4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libiio/libiio.mk

index b36ea3bafef1cddea15071d4d1ee917aa44d43dd..4ce933a0cd8e04438712540194d652c91af1ccde 100644 (file)
@@ -69,9 +69,9 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIBIIO_BINDINGS_PYTHON),y)
 ifeq ($(BR2_PACKAGE_PYTHON),y)
-LIBIIO_DEPENDENCIES += python
+LIBIIO_DEPENDENCIES += host-python-setuptools python
 else ifeq ($(BR2_PACKAGE_PYTHON3),y)
-LIBIIO_DEPENDENCIES += python3
+LIBIIO_DEPENDENCIES += host-python3-setuptools python3
 endif
 LIBIIO_CONF_OPTS += -DPYTHON_BINDINGS=ON
 else