p11-kit: fix detection of certificates path
authorBaruch Siach <baruch@tkos.co.il>
Fri, 26 Oct 2018 06:29:13 +0000 (09:29 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 26 Oct 2018 08:34:18 +0000 (10:34 +0200)
The p11-kit configure script looked for certificates location on the
host. This doesn't work well with cross compilation. Make the
certificates patch depend on BR2_PACKAGE_CA_CERTIFICATES, and set the
right target location of the path.

Fixes:
http://autobuild.buildroot.net/results/295/295614d4aa3db9bb35bebbe56e38110f5a2de178/
http://autobuild.buildroot.net/results/0fb/0fb454ca0df74a8585cffe8f5d1f5d23cdfdbec6/
http://autobuild.buildroot.net/results/ef7/ef71f3d67afba547b5167253fb02476e59152803/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/p11-kit/p11-kit.mk

index d4cf9bc09c4c16d4951a21b2e88197b4632bde80..10b5cc0393007d35668b2b8f47860ad39aa8f645 100644 (file)
@@ -14,4 +14,10 @@ P11_KIT_CONF_ENV = ac_cv_have_decl_program_invocation_short_name=yes \
 P11_KIT_LICENSE = BSD-3-Clause
 P11_KIT_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_CA_CERTIFICATES),y)
+P11_KIT_CONF_OPTS += --with-trust-paths=/etc/ssl/certs/ca-certificates.crt
+else
+P11_KIT_CONF_OPTS += --without-trust-paths
+endif
+
 $(eval $(autotools-package))