package/znc: fix build with cmake < 3.10
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 2 Oct 2019 17:51:20 +0000 (19:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 2 Oct 2019 19:03:04 +0000 (21:03 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/991dd1d74f00f027a905d2ec3ad1a1b2b723f978

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/znc/znc.mk

index 78e1410b68a82708db5506f96cff942e623f74d9..54dc63f4eaf00d3bb5e2fe0b432d1c44248b21dc 100644 (file)
@@ -11,6 +11,11 @@ ZNC_LICENSE_FILES = LICENSE
 ZNC_DEPENDENCIES = host-pkgconf
 ZNC_CONF_OPTS = -DWANT_CYRUS=OFF -DWANT_I18N=OFF -DWANT_PERL=OFF
 
+# Before CMake 3.10, passing THREADS_PTHREAD_ARG=OFF was needed to
+# disable a try_run() call in the FindThreads tests, which caused a
+# build failure when cross-compiling.
+ZNC_CONF_OPTS += -DTHREADS_PTHREAD_ARG=OFF
+
 ifeq ($(BR2_PACKAGE_ICU),y)
 ZNC_DEPENDENCIES += icu
 ZNC_CONF_OPTS += -DWANT_ICU=ON