package/libxkbcommon: fix builds with/without X11
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 27 Dec 2014 16:22:29 +0000 (17:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 16:28:19 +0000 (17:28 +0100)
We need to explicitly disable X11 support when X11 is not available.
Conversely, when it is, we need to add the required dependencies.

Fixes a slew of autobuild failures:
    http://autobuild.buildroot.org/results/587/58794f894a4950b77e38d5fc877852d6cc507d8c/
    http://autobuild.buildroot.org/results/927/92741f6b9b7909b226c200e453ac6cee8af5abd6/
    http://autobuild.buildroot.org/results/51c/51cb09f7f267319948c685f905e29afe99f59589/
    ...

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Fatih Aşıcı <fatih.asici@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libxkbcommon/Config.in
package/libxkbcommon/libxkbcommon.mk

index 0a52c6f43f0f6a01712f591515d82d037c6e188c..4da12897f284faf3c86b58cb5c7571cfa4d5e219 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_LIBXKBCOMMON
        bool "libxkbcommon"
+       select BR2_PACKAGE_LIBXCB if BR2_PACKAGE_XORG7
        help
          xkbcommon is a keymap compiler and support library which
          processes a reduced subset of keymaps as defined by the XKB
index 2d305069098bbfd0afad8f00c6aab840f03c5c06..12d5f1614716ab1d0048191fe4215528d669b51b 100644 (file)
@@ -15,4 +15,11 @@ LIBXKBCOMMON_DEPENDENCIES = host-bison host-flex
 # uses C99 features
 LIBXKBCOMMON_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
 
+ifeq ($(BR2_PACKAGE_XORG7),y)
+LIBXKBCOMMON_CONF_OPTS += --enable-x11
+LIBXKBCOMMON_DEPENDENCIES += libxcb
+else
+LIBXKBCOMMON_CONF_OPTS += --disable-x11
+endif
+
 $(eval $(autotools-package))