package/s6-networking: fix dependency when libressl is enabled
authorRicardo Martincoski <ricardo.martincoski@gmail.com>
Sun, 27 Jan 2019 18:59:36 +0000 (16:59 -0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 Jan 2019 21:14:48 +0000 (22:14 +0100)
Commit "c5b85231fb s6-networking: enable SSL if libressl is selected"
actually dropped the dependency on s6-dns and s6 when libressl is
enabled.
Fix this by using += inside the conditional code.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/s6-networking/s6-networking.mk

index 7c9f087051d07657f5830cea12389be5ac522123..b621eb225d24b1b415fbe6141a745bfd0fbe7b77 100644 (file)
@@ -25,7 +25,7 @@ S6_NETWORKING_CONF_OPTS = \
 
 ifeq ($(BR2_PACKAGE_LIBRESSL),y)
 S6_NETWORKING_CONF_OPTS += --enable-ssl=libressl
-S6_NETWORKING_DEPENDENCIES = libressl
+S6_NETWORKING_DEPENDENCIES += libressl
 endif
 
 define S6_NETWORKING_CONFIGURE_CMDS