libnl: bump to version 3.2.23
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 2 Dec 2013 10:38:56 +0000 (07:38 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Dec 2013 10:41:34 +0000 (11:41 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libnl/libnl-0001-do-not-compile-some-address-families-when-not-available.patch [new file with mode: 0644]
package/libnl/libnl.mk

diff --git a/package/libnl/libnl-0001-do-not-compile-some-address-families-when-not-available.patch b/package/libnl/libnl-0001-do-not-compile-some-address-families-when-not-available.patch
new file mode 100644 (file)
index 0000000..1255041
--- /dev/null
@@ -0,0 +1,63 @@
+From 4f075a4fd1a1d6cbbe81f02f25063a8197fef746 Mon Sep 17 00:00:00 2001
+From: Cong Wang <xiyou.wangcong@gmail.com>
+Date: Fri, 8 Nov 2013 11:32:13 -0800
+Subject: [PATCH] do not compile some address families when not available
+
+This fixes the following error while compiling libnl3 on CentOS5:
+
+addr.c:1027: error: 'AF_RDS' undeclared here (not in a function)
+addr.c:1033: error: 'AF_CAN' undeclared here (not in a function)
+addr.c:1034: error: 'AF_TIPC' undeclared here (not in a function)
+addr.c:1036: error: 'AF_IUCV' undeclared here (not in a function)
+addr.c:1037: error: 'AF_RXRPC' undeclared here (not in a function)
+addr.c:1038: error: 'AF_ISDN' undeclared here (not in a function)
+addr.c:1039: error: 'AF_PHONET' undeclared here (not in a function)
+make[2]: *** [addr.lo] Error 1
+
+Signed-off-by: Cong Wang <xiyou.wangcong@gmail.com>
+Signed-off-by: Thomas Graf <tgraf@suug.ch>
+---
+ lib/addr.c | 14 ++++++++++++++
+ 1 file changed, 14 insertions(+)
+
+diff --git a/lib/addr.c b/lib/addr.c
+index 86e7e58..54d2b1d 100644
+--- a/lib/addr.c
++++ b/lib/addr.c
+@@ -1024,19 +1024,33 @@ static const struct trans_tbl afs[] = {
+       __ADD(AF_ASH,ash)
+       __ADD(AF_ECONET,econet)
+       __ADD(AF_ATMSVC,atmsvc)
++#ifdef AF_RDS
+       __ADD(AF_RDS,rds)
++#endif
+       __ADD(AF_SNA,sna)
+       __ADD(AF_IRDA,irda)
+       __ADD(AF_PPPOX,pppox)
+       __ADD(AF_WANPIPE,wanpipe)
+       __ADD(AF_LLC,llc)
++#ifdef AF_CAN
+       __ADD(AF_CAN,can)
++#endif
++#ifdef AF_TIPC
+       __ADD(AF_TIPC,tipc)
++#endif
+       __ADD(AF_BLUETOOTH,bluetooth)
++#ifdef AF_IUCV
+       __ADD(AF_IUCV,iucv)
++#endif
++#ifdef AF_RXRPC
+       __ADD(AF_RXRPC,rxrpc)
++#endif
++#ifdef AF_ISDN
+       __ADD(AF_ISDN,isdn)
++#endif
++#ifdef AF_PHONET
+       __ADD(AF_PHONET,phonet)
++#endif
+ #ifdef AF_IEEE802154
+       __ADD(AF_IEEE802154,ieee802154)
+ #endif
+--
+1.8.3.2
+
index 3b56bc87ba0963e0ceb6c72a95a7dd8494f24975..7d8ba6571607cb60b34c61d0d2aee221dfbf4ab7 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBNL_VERSION = 3.2.21
+LIBNL_VERSION = 3.2.23
 LIBNL_SITE = http://www.infradead.org/~tgr/libnl/files
 LIBNL_LICENSE = LGPLv2.1+
 LIBNL_LICENSE_FILES = COPYING