libv4l: Add new package libv4l
authorKlaus Schwarzkopf <schwarzkopf@sensortherm.de>
Mon, 7 Mar 2011 17:21:18 +0000 (18:21 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Apr 2011 20:56:38 +0000 (22:56 +0200)
[Peter: move to hw section]
Signed-off-by: Klaus Schwarzkopf <schwarzkopf@sensortherm.de>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libv4l/Config.in [new file with mode: 0644]
package/libv4l/libv4l.mk [new file with mode: 0644]

index f459c1bd83758640b7359e01be6c228074f88347..ea39570417ac7079b97339d525c5cb8214271cc4 100644 (file)
@@ -179,6 +179,7 @@ source "package/input-tools/Config.in"
 source "package/iostat/Config.in"
 source "package/irda-utils/Config.in"
 source "package/kbd/Config.in"
+source "package/libv4l/Config.in"
 source "package/lm-sensors/Config.in"
 source "package/lsuio/Config.in"
 source "package/lvm2/Config.in"
diff --git a/package/libv4l/Config.in b/package/libv4l/Config.in
new file mode 100644 (file)
index 0000000..1620b93
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBV4L
+       bool "libv4l"
+       depends on BR2_LARGEFILE
+       help
+         libv4l is an accompanying collection of libraries that adds a thin
+         abstraction layer on top of video4linux2 (V4L2) devices.
+
+         http://freshmeat.net/projects/libv4l
+
+comment "libv4l requires a toolchain with LARGEFILE support"
+        depends on !BR2_LARGEFILE
diff --git a/package/libv4l/libv4l.mk b/package/libv4l/libv4l.mk
new file mode 100644 (file)
index 0000000..a72320e
--- /dev/null
@@ -0,0 +1,29 @@
+#############################################################
+#
+# libv4l
+#
+#############################################################
+LIBV4L_VERSION = 0.8.3
+LIBV4L_SOURCE = v4l-utils-$(LIBV4L_VERSION).tar.bz2
+LIBV4L_SITE = http://linuxtv.org/downloads/v4l-utils/
+LIBV4L_INSTALL_STAGING = YES
+LIBV4L_MAKE_OPTS = PREFIX=/usr
+
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+       LIBV4L_MAKE_OPTS += LINKTYPE=static
+endif
+
+define LIBV4L_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)/lib $(LIBV4L_MAKE_OPTS)
+endef
+
+define LIBV4L_INSTALL_STAGING_CMDS
+       $(MAKE) -C $(@D)/lib DESTDIR=$(STAGING_DIR) $(LIBV4L_MAKE_OPTS) install
+endef
+
+define LIBV4L_INSTALL_TARGET_CMDS
+       $(MAKE) -C $(@D)/lib DESTDIR=$(TARGET_DIR) $(LIBV4L_MAKE_OPTS) install
+endef
+
+$(eval $(call GENTARGETS,package,libv4l))
+