ncurses: build statically when BR2_PREFER_STATIC_LIB
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 29 Jun 2012 14:11:50 +0000 (16:11 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 29 Jun 2012 14:40:04 +0000 (16:40 +0200)
--disable-static is no more. Only try to install .so files if not
configured for static linking.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ncurses/ncurses.mk

index 10a55ddc5e57006a5bd71c17c14c3a6f72379194..afeb41b8380bf13c5d9d5dbbcc351ba4f93fabad 100644 (file)
@@ -29,7 +29,7 @@ NCURSES_INSTALL_STAGING = YES
 NCURSES_DEPENDENCIES = host-ncurses
 
 NCURSES_CONF_OPT = \
-       --with-shared \
+       $(if $(BR2_PREFER_STATIC_LIB),--without-shared,--with-shared) \
        --without-cxx \
        --without-cxx-binding \
        --without-ada \
@@ -41,8 +41,7 @@ NCURSES_CONF_OPT = \
        --enable-echo \
        --enable-const \
        --enable-overwrite \
-       --enable-broken_linker \
-       --disable-static
+       --enable-broken_linker
 
 ifneq ($(BR2_ENABLE_DEBUG),y)
 NCURSES_CONF_OPT += --without-debug
@@ -79,6 +78,8 @@ define NCURSES_INSTALL_TARGET_DEVFILES
 endef
 endif
 
+ifneq ($(BR2_PREFER_STATIC_LIB),y)
+
 ifeq ($(BR2_PACKAGE_NCURSES_TARGET_PANEL),y)
 define NCURSES_INSTALL_TARGET_PANEL
        cp -dpf $(NCURSES_DIR)/lib/libpanel.so* $(TARGET_DIR)/usr/lib/
@@ -97,9 +98,11 @@ define NCURSES_INSTALL_TARGET_MENU
 endef
 endif
 
+endif
+
 define NCURSES_INSTALL_TARGET_CMDS
        mkdir -p $(TARGET_DIR)/usr/lib
-       cp -dpf $(NCURSES_DIR)/lib/libncurses.so* $(TARGET_DIR)/usr/lib/
+       $(if $(BR2_PREFER_STATIC_LIB),,cp -dpf $(NCURSES_DIR)/lib/libncurses.so* $(TARGET_DIR)/usr/lib/)
        $(NCURSES_INSTALL_TARGET_PANEL)
        $(NCURSES_INSTALL_TARGET_FORM)
        $(NCURSES_INSTALL_TARGET_MENU)