weston: egl requires gles as well
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 4 Apr 2016 18:34:01 +0000 (15:34 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 5 Apr 2016 19:34:06 +0000 (21:34 +0200)
>From configure.ac lines 83-89:

AC_ARG_ENABLE(egl, [  --disable-egl],,
enable_egl=yes)
AM_CONDITIONAL(ENABLE_EGL, test x$enable_egl = xyes)
if test x$enable_egl = xyes; then
AC_DEFINE([ENABLE_EGL], [1], [Build Weston with
EGL support])
PKG_CHECK_MODULES(EGL, [egl glesv2])
PKG_CHECK_MODULES([EGL_TESTS], [egl glesv2 wayland-client
wayland-egl])

It also requires wayland-egl which is only provided by mesa3d for now,
hence make it conditional on mesa3d egl+gles.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/weston/weston.mk

index 2891fe3246ba68cf47425d80dade96a2e4552f5e..7aa21304fc02d1181fc7d1b1b4e0ed90b72f483c 100644 (file)
@@ -49,7 +49,7 @@ WESTON_CONF_OPTS += --disable-weston-launch
 endif
 
 # Needs wayland-egl, which normally only mesa provides
-ifeq ($(BR2_PACKAGE_HAS_LIBEGL)$(BR2_PACKAGE_MESA3D_OPENGL_EGL),yy)
+ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_ES)$(BR2_PACKAGE_MESA3D_OPENGL_GLES),yy)
 WESTON_CONF_OPTS += --enable-egl
 WESTON_DEPENDENCIES += libegl
 else